99' TJ electrical problem - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-13-2014, 06:03 AM   #1
Newb
 
Join Date: Jan 2014
Posts: 7
99' TJ electrical problem

My head lights take awhile to come on, sometimes 30 minutes.
I also lose power to dash board gauges.

Any idea's of what the cause is.

redwrangler1999 is offline   Quote
Old 03-13-2014, 09:31 AM   #2
Supporting Member

5-Year WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Powderly, TX
Posts: 8,166
Is it starting okay? If it is turning over slow, it's probably battery connections or a bad ground connection. Specifically, check the ground connection between engine and frame. Make sure all connections are clean and tight.

__________________
Dennis
Water Dog is offline   Quote
Old 04-02-2014, 05:17 PM   #3
Newb
 
Join Date: Jan 2014
Posts: 7
Ended up being actual switch.
redwrangler1999 is offline   Quote
Old 04-03-2014, 12:54 PM   #4
Jeeper
 
SlackAttack's Avatar
 
Join Date: Jan 2014
Location: Palmer Lake, CO
Posts: 66
I was going to say, I've seen that issue and it was the switch.
SlackAttack is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 12:27 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC