AC control broken? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-26-2009, 07:18 PM   #1
Jeeper
 
Join Date: Mar 2007
Posts: 52
AC control broken?

Hi there!

I have an issue with my A/C (rotary) control - when switching between the settings (e.g., defrost, middle vents, middle and feet, etc.) I cannot feel it 'clicking' into the setting anymore. Also, the setting i choose is not necessarily what is happening - I put it on defrost, but air is blowing only out of the vents in the dashboard facing me. I also cannot get it to the O setting.

I read about issues with the vacuum pump/hose, but I thought it would then default into the defrost setting. A brief look under the hood seemed to show that the hose, where it comes through the firewall, is still attached.

It used to work fine, and i could 'click' through all the settings, but one day it just didn't do it anymore. Any idea what it could be?

Thanks for the help!

It's a 2000 Sahara btw.

catoct is offline   Quote
Old 03-26-2009, 10:10 PM   #2
Jeeper
 
jeeperx2's Avatar
 
Join Date: Feb 2006
Location: Des Moines, Iowa
Posts: 353
take the knob off and look at it . it is probably broke. mine is .

__________________
2004 TJ
4" suspension lift
sye/TW driveshaft
NTH degree c/a
2" body lift
aussie locker
Rancho rs9000 shocks
tube bumpers
winch
33x12.50 firestone's
cold air intake
throttle body spacer
rear led's
sony MEX5DI deck
big ol amp
infinity speakers
-------------------> http://miobi.org/main.htm
--------------------> http://www.jocci.com/
jeeperx2 is offline   Quote
Old 03-27-2009, 06:32 AM   #3
Jeeper
 
Join Date: Mar 2007
Posts: 52
Quote:
Originally Posted by jeeperx2 View Post
take the knob off and look at it . it is probably broke. mine is .
Thanks! Can I just pull it off, or do I need to disassemble anything? I gave it a tug and it didn't come off right away, so i just want to make sure I don't break anything else by pulling harder....
catoct is offline   Quote
Old 03-27-2009, 11:04 PM   #4
Jeeper
 
n8smitty's Avatar
 
Join Date: Dec 2007
Location: Jupiter, Fl
Posts: 335
Send a message via AIM to n8smitty
two of mine broke about 2 weeks after buying my jeep (used). I had to change the temp with a pair of pliers until I got new ones. I replaced them with the billet ones and they shouldn't break. plus they look good.
n8smitty is offline   Quote
Old 03-30-2009, 10:59 AM   #5
Jeeper
 
Join Date: Jan 2007
Posts: 33
Yeah, I am getting the same thing right now. You can just pull off the knobs. Mine is cracked, so it works some of the time.
gnu2308 is offline   Quote
Old 03-30-2009, 12:21 PM   #6
Jeeper
 
Join Date: Aug 2007
Location: minot north dakota
Posts: 45
mine broke too might have to tug a little bit the first time the plastic must dry out over time they sell billet ones and oem stuff on most of the jeep parts websites each of the three knobs on my 99 look the same but have different positions where the D shaft goes into them so if you order just one make sure you get the right one
__________________
jonnybravo is offline   Quote
Old 03-31-2009, 07:15 PM   #7
Jeeper
 
TerryFaust's Avatar
 
Join Date: Oct 2008
Posts: 137
mine broke as well, but in texas my season has started so i have no need for heater or A/C ... tops off and gone WOO
__________________
2000 Jeep Wrangler Sahara TJ
S&B Cold Air Intake
31'' BFG A/T
4.0L I-6 5SPD Man
"going topless"
Roads? Where were going we dont need roads.
TerryFaust is offline   Quote
Old 03-31-2009, 07:31 PM   #8
Jeeper
 
Join Date: Mar 2007
Posts: 52
Thanks for all your replies, I did finally get it off, and it is broken. That's a relief, just a few bucks and I'll be good to go!

catoct is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
control arms mrbigjeep TJ General Discussion Forum 8 08-23-2010 10:19 AM
Rubicon Express Control arms, 36" Iroks & TJ D30 shafts tweba99 Classifieds Archive 0 03-19-2007 02:21 PM
HVAC control problems.......... rooster2 TJ Tech Forum 1 07-06-2006 10:46 AM
Lunchbox Lockers and broken axles? U.S.MarineLJ TJ General Discussion Forum 14 03-12-2006 01:21 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:34 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC