Alternator plug problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-25-2013, 09:51 PM   #1
Jeeper
 
vmaxaholic's Avatar
 
Join Date: Mar 2013
Location: Avon, CT
Posts: 54
Alternator plug problems

Hi, everybody! I'm a newbee here, and I just bought my first Wrangler. It's a 93 YJ with the 4.0, 5 sp, and 99k. I bought it knowing that it needed an alternator and battery. I thought, ok no sweat. I've done many of these in my time. But my problem is with the alternator plug. The two large (maybe 6 gauge) wires came off easy enough, but the other two flat spades that are coming out of the black plastic box are giving me the issue. The hardware that connects them to the alternator is completely rusted. To the point that you can't even tell if there's a nut on a threaded stud or what. It looks like two small posts of solid rust. My question is how would any of you resolve this? I definitely don't want to butcher the copper spades, but I feel like I might have to just to be able to remove the alternator. I'm gonna try to attach a pic, but not sure if my laptop will let me. Any help will be greatly appreciated!!!!
Attached Thumbnails
Click image for larger version

Name:	alternator plug.jpg
Views:	40
Size:	182.8 KB
ID:	290613  

vmaxaholic is offline   Quote Quick Reply
Old 08-25-2013, 10:00 PM   #2
Jeeper
 
Majnoon's Avatar
 
Join Date: Apr 2013
Location: Springfield Missouri
Posts: 3,144
I would drill the bolts outa the alternator. Even if you damaged the spades they will still conduct. Maybe even take channel locks and use a roll/pry action to try and break/pull the bolts Out. Also there is a dedicated YJ thread. They may know more this is the TJ one.

Majnoon is offline   Quote Quick Reply
Old 08-26-2013, 05:03 PM   #3
Jeeper
 
vmaxaholic's Avatar
 
Join Date: Mar 2013
Location: Avon, CT
Posts: 54
Dammit....I thought this WAS the YJ thread... Did I mention, newbee??.. I was also thinking about finding this plug in a junk yard, cutting the wires and cutting this one out. Then just splice in the new used one.. Don't know if all of these rectifiers/regulators are the same...
vmaxaholic is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 09:05 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC