Another TPS problem... Am I missing something?? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 06-28-2010, 05:33 PM   #1

WF Supporting Member
Martinez_Coins's Avatar
Join Date: Feb 2010
Location: Springfield, MO
Posts: 208
Angry Another TPS problem... Am I missing something??

So this morning I was driving around town getting ready for a road trip tomorrow and my check engine light came on and me engine idle speed went way low, so low that as I pulled into AutoZone it died.

So I had AZ put a code reader on and it said it was the infamous TPS. I shelled out $80 for a new one and went home and put it on. After I started it up it started doing the same thing…. Could I have gotten a TPS that was DOA or am I missing something?

According to the dash code it is has a P0123 code right now.

I have a 2001 Jeep Sahara with the 4.0L I6

I need to hit the road first thing in the morning. Once I get out of town and its always in gear there shouldn’t be a problem but I would rather have it fixed today so I don’t have to worry about it.

Any help is appreciated!!

Martinez_Coins is offline   Quote
Old 06-28-2010, 06:50 PM   #2
Indy's Avatar
Join Date: Jun 2009
Location: Bay Area
Posts: 559
Could be DOA ... try another one ... if still the same check your wires.
98 TJ 4.7 Stroker!!! Unichip tuner, HPD30/D44, 4.56, Detroit Locker in rear axle, 3.25RC SL, 1.25BL, 1MML, 35x12.50x15, Cager Softs 15x8, XRC10 winch, Rancho 9000XL shocks with wireless remote
Indy is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
2400 miles on new jk having trans problem NTJeep JK Tech Forum 4 01-14-2009 02:03 AM
electrical!!! evas98tj TJ Tech Forum 3 10-10-2008 11:18 PM
42RLE Tranny Problem nicolas-eric TJ Tech Forum 8 09-21-2008 07:29 PM
Heater / Blower Problem 2000 Wrangler dougman1971 TJ Tech Forum 0 09-17-2008 08:56 AM
Window Crank woes, did any one else have this problem? virtual_verve11 JK Tech Forum 2 04-07-2007 10:57 AM

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 07:16 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC