bad starter? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-24-2010, 10:43 AM   #1
Jeeper
 
asphaltaddict's Avatar
 
Join Date: Jun 2010
Location: Asheville
Posts: 52
bad starter?

quick question. For bout a month my jeep squeels like a bad fanbelt for about 5 seconds after it starts. Yesterday i tried to start it and nothing. I had full power to all the accessories but nothing. No clicking or buzzing. I rolled it off and drove it home but when i shut it off and tried to start it again still nada. Im assuming i have a bad starter but after doing a little research it seems a few others have had a similar problem. Some have mentioned their needles jumping and mine doesn't do that at all. the only thing i noticed then the last time i started it the airbag light came on. Any suggestions or theories before i go buy a new starter? Kinda wondering if maybe a sensor with the airbag might be acting as a kill switch. Either that or my Jeep is simply having an off week lol

asphaltaddict is offline   Quote Quick Reply
Old 07-24-2010, 10:46 AM   #2
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 31,150
Images: 2
That doesn't sound like a bad starter, have you tried removing, cleaning, then reinstalling the battery connectors so they are tightly connected to the battery? Bad battery connections have been the cause of many battery and starter replacements when there was nothing wrong with either. If that doesn't help, I would have the battery load tested to determine its true health.

__________________
When you have a choice, buy American.

Jerry Bransford is online now   Quote Quick Reply
Old 07-24-2010, 11:09 AM   #3
Jeeper
 
jspeer1130's Avatar
 
Join Date: Apr 2010
Location: North Canton, Ohio
Posts: 315
not sure if it applies to the jeep as much but I know on my pt cruiser there was the main lead going to the starter and for some reason the bolt that held the cable on was stripped and it would make contact and then not make contact. Ended up tightening it down and putting some locktite on it and it stayed solid for 2 years until the starter went out.
jspeer1130 is offline   Quote Quick Reply
Old 07-24-2010, 11:20 AM   #4
Jeeper
 
asphaltaddict's Avatar
 
Join Date: Jun 2010
Location: Asheville
Posts: 52
I'll try that when i get off work I was thinking that since it didnt seem like there was any loss in the power to all my accessories the battery was phone but A lot of people have said the same thing. Seems like another weird jeep quirk lol. Next stop death wobble correction!
asphaltaddict is offline   Quote Quick Reply
Old 07-25-2010, 09:29 AM   #5
Jeeper
 
asphaltaddict's Avatar
 
Join Date: Jun 2010
Location: Asheville
Posts: 52
Wow after all that I had a bad fuse.
asphaltaddict is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
possible starter problem kelly TJ General Discussion Forum 5 03-16-2011 06:26 PM
New battery Starter and starter relay and still won't start. Any ideas imowt TJ Tech Forum 4 08-11-2010 07:59 PM
New battery, starter and starter relay Yet it still won't start. Any Ideas? imowt TJ Tech Forum 0 02-02-2010 05:30 PM
Won't start (battery and starter checked ok) rpxr400 YJ Tech Forum 10 02-09-2009 08:51 AM
Starter problems PLEASE HELP!!! 97REDTJ TJ Tech Forum 9 01-15-2007 07:36 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:58 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC