Blinker lights not working at all! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-20-2013, 08:11 PM   #1
Newb
 
Join Date: Apr 2013
Posts: 4
Blinker lights not working at all!

Hello everyone! I am trying to figure out an issue I've been having with my 03 jeep rubicon. For some time now, I had a turn signal switch that appeared to be going bad. It would touch the knob barely, and it would light up my fog lights, and then when I would jiggle it they would go off. I assumed this was going bad and decided to change the switch. So today I went out and started my jeep, and the battery was dead. Just assumed the switch was on, as I disconnected my lights. I went to autozone for a new switch, and installed it. Now I have no turn signals at all. The signals worked up until I switched this out. I checked the fuse in the glove compartment and not burned out. Haven't checked turn signal bulbs yet, but the dash doesn't light up at all when the signal is turned either way. If I push down the hazard button I get nothing either. I'm stumped and could really use some assistance!!! I don't know what to do next

I appreciate any assistance or knowledge you can help with!

Thanks!

Russ

Jeeper2003 is offline   Quote Quick Reply
Old 04-20-2013, 09:00 PM   #2
Jeeper
 
Join Date: Jan 2013
Location: Appleton, WI
Posts: 537
Send a message via Yahoo to ChaddG
relay?
plug behind the dash somewhere?
my only two guesses

ChaddG is offline   Quote Quick Reply
Old 04-21-2013, 12:43 PM   #3
Newb
 
Join Date: Apr 2013
Posts: 4
Ok, so here's what I've done so far today... Took off by rear light guards as some say I may lose a ground. I replaced all the bulbs, replaced the relay on the switch, and what I found was I had a blown fuse at the msw fuse under the hood. As soon as I put in a new 20a fuse, it popped again. Can't figure out what is causing this, I have a short somewhere and have no idea where. I'm stumped

Any help would be greatly appreciated!

Russ
Jeeper2003 is offline   Quote Quick Reply
Old 04-21-2013, 12:47 PM   #4
Creepy Crawler

WF Supporting Member
 
BLK00TJ's Avatar
 
Join Date: Nov 2010
Posts: 3,194
Got blinker fluid filled up?







Sorry. Couldn't resist.
__________________
Wheel. Break/Test. Repair/Upgrade. Repeat
BLK00TJ's YouTube Channel -- BLK00TJ's Build
BLK00TJ is offline   Quote Quick Reply
Old 04-21-2013, 12:57 PM   #5
Jeeper
 
Lando25's Avatar
 
Join Date: Feb 2011
Location: Southern Minnesota
Posts: 1,145
Quote:
Originally Posted by Jeeper2003 View Post
Ok, so here's what I've done so far today... Took off by rear light guards as some say I may lose a ground. I replaced all the bulbs, replaced the relay on the switch, and what I found was I had a blown fuse at the msw fuse under the hood. As soon as I put in a new 20a fuse, it popped again. Can't figure out what is causing this, I have a short somewhere and have no idea where. I'm stumped

Any help would be greatly appreciated!

Russ
There's another fuse behind the glove box in my 02. Not sure if its in your 03, but its worth a shot.
__________________
sic vis pacem para bellum
OlllllllO
Lando25 is offline   Quote Quick Reply
Old 04-21-2013, 01:14 PM   #6
Newb
 
Join Date: Apr 2013
Posts: 4
Quote:
Originally Posted by BLK00TJ View Post
Got blinker fluid filled up?







Sorry. Couldn't resist.
I wish it was as easy as filling blinker fluid
This is driving me crazy!!!
Jeeper2003 is offline   Quote Quick Reply
Old 04-21-2013, 04:14 PM   #7
Newb
 
Join Date: Apr 2013
Posts: 4
Turns out, the new switch was defective. Jeep is back in business
Jeeper2003 is offline   Quote Quick Reply
Old 04-21-2013, 04:16 PM   #8
Creepy Crawler

WF Supporting Member
 
BLK00TJ's Avatar
 
Join Date: Nov 2010
Posts: 3,194
Glad you got it worked out. Now top off the blinker fluid!

__________________
Wheel. Break/Test. Repair/Upgrade. Repeat
BLK00TJ's YouTube Channel -- BLK00TJ's Build
BLK00TJ is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 03:19 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC