Blower motor issues.... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-06-2013, 07:10 PM   #1
Jeeper
 
reissigree's Avatar
 
Join Date: Apr 2012
Posts: 517
Blower motor issues....

So my blower motor only works on speed four, not 1-3. I replaced the blower motor resistor which did nothing. Today I wiggled the wires around and got everything to work, when I tested it a couple of times it stopped working. I noticed that the relay that comes from these wires was warm-hot. What could be the issue? Thanks guys!

reissigree is offline   Quote Quick Reply
Old 08-06-2013, 07:16 PM   #2
Jeeper
 
ltsrapcon's Avatar
 
Join Date: Jun 2012
Location: Johnstown PA
Posts: 463
Same with my 06


Mine is getting there. Speeds 1-3 you hardly know they are on but full power works great. Im worried that max power will soon follow the other three and stop working.
Mine is an 06TJ

ltsrapcon is offline   Quote Quick Reply
Old 08-06-2013, 07:37 PM   #3
Jeeper
 
Steeljag's Avatar
 
Join Date: Aug 2012
Location: Central Fl.
Posts: 510
I've had mystery AC the last few weeks. Sometimes the fan blows ....sometimes not. I've not had time to play with it.....thank goodness it's only a weekend run around vehicle for me.
__________________
2014 Jeep Wrangler JKR
Copper Canyon
Yeah,I gotta change the Pic
Love the Rubicon, but already miss the TJ.
Steeljag is offline   Quote Quick Reply
Old 08-06-2013, 07:43 PM   #4
Newb
 
Join Date: Oct 2011
Location: Knoxville
Posts: 8
This might help you to get started on where to fix it.
http://www.knoxoffroad.com/forums/viewtopic.php?t=3151
mjwithatj is offline   Quote Quick Reply
Old 08-06-2013, 08:11 PM   #5
Supporting Member

WF Supporting Member
 
JimsJeep's Avatar
 
Join Date: Feb 2012
Location: Long Branch NJ
Posts: 1,279
Mine was the fan speed switch, works fine since then.
JimsJeep is offline   Quote Quick Reply
Old 08-10-2013, 09:05 PM   #6
Jeeper
 
Steeljag's Avatar
 
Join Date: Aug 2012
Location: Central Fl.
Posts: 510
Also realize now
that when my air bag light comes on the fan goes off ? Happened twice today headed over to the beach. Left in the heat without AC and air bag light on......20 minutes later while pulling into a store parking lot the AC fan came on and the airbag light light went off.....crazy!
__________________
2014 Jeep Wrangler JKR
Copper Canyon
Yeah,I gotta change the Pic
Love the Rubicon, but already miss the TJ.
Steeljag is offline   Quote Quick Reply
Old 08-10-2013, 09:22 PM   #7
Jeeper
 
Gold Miner's Avatar
 
Join Date: Jan 2013
Location: way up thar
Posts: 491
Quote:
Originally Posted by JimsJeep View Post
Mine was the fan speed switch, works fine since then.
Same here... replaced the fan speed switch and all three knobs about two years ago and everything still works fine but I notice that the blower door switch knob (aftermarket metal knob) gets super hot after a while whether I'm running heat or AC. I know that if it were the OEM plastic knob that it would have melted by now. Somethin ain't right in there but it all continues to work well. I posted a Q about this a while back but got no responses.
__________________
'01 Sahara, Original Owner
BDS, OME, Metalcloak,
JKS Disco, Rough Trail, Kargo Master,.... bla bla bla, never done
Ghost Creek Mine, Owner ... Mitchell/Yooper Placer Mine, Owner
Only thing we have to fear is, fear itself....................................... and bears
Gold Miner is offline   Quote Quick Reply
Old 08-10-2013, 09:29 PM   #8
Jeeper
 
cueball13's Avatar
 
Join Date: Jun 2013
Posts: 273
You guys have to do mod to put in relays for the blower motor. No more hot switches which cause the erratic fan behavior
cueball13 is offline   Quote Quick Reply
Old 08-10-2013, 10:35 PM   #9
Jeeper
 
cabenso's Avatar
 
Join Date: Aug 2012
Location: Upstate SC
Posts: 65
ya, I only have 1,2 and 4. Since I don't have ac... it's not even really worth it turning the air on. I usually just open a window rain or shine.
cabenso is offline   Quote Quick Reply
Old 08-10-2013, 11:03 PM   #10
Newb
 
Join Date: Sep 2012
Posts: 8
I had a similar problem on my 97. I found the grease on my slide lever for Vent...AC...Heater...etc had thickened and was intermittently allowing the motor to run and not run. I cleaned the switch with some spray degreaser and applied a new light coat of grease. It's worked fine since.
hknapp is offline   Quote Quick Reply
Old 08-11-2013, 09:12 AM   #11
Jeeper
 
Steeljag's Avatar
 
Join Date: Aug 2012
Location: Central Fl.
Posts: 510
Mine appears to be allot more electrical. I played with it last night and my back up lights are also out when my air bag light is on.

Googling at now and there are several posts about Wranglers with similar issues of no A.C fan and no back up lights when the air bag light is on. What i have not found is the solution. Some have posted their problem was solved with an ignition change, but not all.
__________________
2014 Jeep Wrangler JKR
Copper Canyon
Yeah,I gotta change the Pic
Love the Rubicon, but already miss the TJ.
Steeljag is offline   Quote Quick Reply
Old 08-11-2013, 11:29 AM   #12
Jeeper
 
48Sam's Avatar
 
Join Date: Jun 2013
Location: San Jose, Ca
Posts: 178
Gentlemen,
I found this link a while ago and should work on your issue. It solved my issues.

Jeep Blower Motor Resistor Fix - YouTube
48Sam is offline   Quote Quick Reply
Old 08-11-2013, 12:29 PM   #13
Jeeper
 
cuder's Avatar
 
Join Date: Dec 2011
Posts: 195
This is the same mod in the thread posted in post #4 of this thread. Maybe a little easier to read.

Look at post #50 in this thread and check for melted connector where the picture says "this switch here". Do the relay mod shown in the thread and that plug and the fan switch will not melt again.
Fried A/C speed switch w/pics! - Page 2 - JeepForum.com
__________________
Member of Lone Star Jeep Club
cuder is offline   Quote Quick Reply
Old 09-10-2013, 09:52 PM   #14
Jeeper
 
UFOtestpilot's Avatar
 
Join Date: Nov 2012
Location: Portland, Oregon
Posts: 1,822
Pulling this back up to get some clarification on a question or two I have.

I have a 1999 with A/C

I ordered the VDO Blower (which apparently some like, and some don't) and the switch assembly from www.rockauto.com simply because I am in the midst of a huge home project and when I dig into my A/C issue I want to have the parts to fix it on hand. One day out of the blue my blower stopped working on all speeds. A/C compressor still works, and I have not tracked the ground or power to the blower or the switch. I do have power all the way to the A/C fuse at the glove box.

I've read about the relay mod, and if I understand correctly you don't need to add a relay if you replace the blower motor. There's 155k on the clock before the stock switch went (if that's in fact what it is) so is it safe to say that I could expect similar longevity from the replacement switch as long as I replace the blower motor also?

Please refrain from giving me crap about buying the parts without knowing the problem 100%, it's simply a convenient luxury for me to be able to do so. I'm so deep into projects at work and home that I'm actually dropping off my motorcycle to get rocker box gaskets installed at a shop.

If I need to wire up relays I probably could, but I'm not much of an electrician.
__________________
For some, it is easier to kill the light inside of themselves than it is to fight the darkness all around them.
UFOtestpilot is offline   Quote Quick Reply
Old 09-10-2013, 10:38 PM   #15
Newb
 
Join Date: Sep 2013
Posts: 4
You guys have to do mod to put in relays for the blower motor.
weaselpiuf is offline   Quote Quick Reply
Old 09-11-2013, 12:27 AM   #16
Jeeper
 
crunky's Avatar
 
Join Date: Aug 2013
Location: cape crud ma.
Posts: 127
Strange but after reading this thread I decided to go out and check my fan and heater/AC.
Everything works great except setting number 3. 1,2 and 4 work.

what the poop is that ?

__________________
Some people shouldn't be allowed near tools... then again some Tools shouldn't be allowed near people.
crunky is offline   Quote Quick Reply
Old 09-11-2013, 10:41 PM   #17
Jeeper
 
UFOtestpilot's Avatar
 
Join Date: Nov 2012
Location: Portland, Oregon
Posts: 1,822
I searched, I found the relevant thread, I posed a question with some good points of inquiry, and I got nothing useful. I guess I understand why everyone just starts a new A/C blower thread each day instead of trying to keep it all in one place. Oh well, I'll let y'all know how it works out and what I do when I get to it.
__________________
For some, it is easier to kill the light inside of themselves than it is to fight the darkness all around them.
UFOtestpilot is offline   Quote Quick Reply
Old 11-14-2013, 03:04 PM   #18
Jeeper
 
Steeljag's Avatar
 
Join Date: Aug 2012
Location: Central Fl.
Posts: 510
After a few months of frustration I have my issue corrected. My problem was when started, the air bag light would come on, my AC fan would stop (compresser stayed on), and my back up lights would go out.

I had the ignition replaced and all seems well!

__________________
2014 Jeep Wrangler JKR
Copper Canyon
Yeah,I gotta change the Pic
Love the Rubicon, but already miss the TJ.
Steeljag is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 11:48 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC