bogging down sound when i start my jeep - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-10-2013, 08:57 PM   #1
Jeeper
 
03WranglerRubicon's Avatar
 
Join Date: Jan 2013
Posts: 56
bogging down sound when i start my jeep

My father noticed a weird sound coming out of my jeep when i started it up for the first time the other day. Once the Jeep is turned over it has a period of 3-5 seconds where it runs rough, bogged down, and not normal. Does anyone have an idea of what this might be?

03WranglerRubicon is offline   Quote Quick Reply
Old 06-18-2013, 08:48 PM   #2
Jeeper
 
Scott74d's Avatar
 
Join Date: Mar 2012
Location: Middletown Ct
Posts: 53
Check spark plugs, wires, and distributor cap. Could be time for some new ones.

Scott74d is offline   Quote Quick Reply
Old 06-18-2013, 08:51 PM   #3
Jeeper
 
krisbman's Avatar
 
Join Date: Feb 2012
Location: Cheshire Oregon
Posts: 6,535
Try the plugs, you dont have wires and a distributor cap
krisbman is online now   Quote Quick Reply
Old 06-18-2013, 09:07 PM   #4
Jeeper
 
Scott74d's Avatar
 
Join Date: Mar 2012
Location: Middletown Ct
Posts: 53
They didn't put distributor caps in the 03s?
Scott74d is offline   Quote Quick Reply
Old 06-18-2013, 09:22 PM   #5
Jeeper
 
eagle223's Avatar
 
Join Date: Jun 2011
Location: Bay Area, CA
Posts: 498
Quote:
Originally Posted by Scott74d View Post
They didn't put distributor caps in the 03s?
No, 2000 and up switched to distributor less ignition, also known as coil packs. If I remember the coil pack is somewhere around $175-$200
eagle223 is offline   Quote Quick Reply
Old 06-18-2013, 09:32 PM   #6
Jeeper
 
Scott74d's Avatar
 
Join Date: Mar 2012
Location: Middletown Ct
Posts: 53
Good to know, I have a 99 and mine was bogging down at one point, needed a new cap
Scott74d is offline   Quote Quick Reply
Old 06-19-2013, 10:35 AM   #7
Jeeper
 
03WranglerRubicon's Avatar
 
Join Date: Jan 2013
Posts: 56
I replaced the spark plugs at the end of January. The jeep fires right up but sounds like there is no oil at the top of the motor...(this is my dads words not mine)

03WranglerRubicon is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 07:16 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC