Brake Problems After Mudding - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-31-2008, 02:39 AM   #1
Jeeper
 
nicolas-eric's Avatar
 
Join Date: Jan 2007
Location: Hamburg, Germany
Posts: 5,867
Send a message via ICQ to nicolas-eric Send a message via AIM to nicolas-eric Send a message via MSN to nicolas-eric Send a message via Yahoo to nicolas-eric
Brake Problems After Mudding

Hello.

Last weekend i was mudding and after that my rear drum brakes (D44) and the e-brake donīt work anymore. My TJ is only 12.000 miles young.

I think there good be mud in the brake drum. Is that possible?
If yes how do I have to clean it? Is there a write-up in the internet?

What else could cause the problem?

My front disc brakes also have a weird issue. They work fine, but from 5 mph down to 0 mpgh the brake pedal pulsates and it sounds like the ABS turns on. What could cause this?

Thanks for your help.
nicolas-eric

nicolas-eric is offline   Quote Quick Reply
Old 07-31-2008, 02:48 AM   #2
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
As for the rear drums... a hose will/should take the dirt and mud out. Drum breaks will dry out fine after a little use. As for the e-brake not working... I'd check the cable from the body to the axle and make sure that it's still attached.

The front breaks pulse? Only at low speeds? A pulsing pedal makes me think that a rotor or both may be warped. Remember, you have big 35" tires you're trying to stop with stock breaks, so they will wear out faster and may even get damaged. I'd remove your wheels and inspect them, maybe even remove the rotor to see if its still true and flat.

AzTJ is offline   Quote Quick Reply
Old 07-31-2008, 02:59 AM   #3
Jeeper
 
nicolas-eric's Avatar
 
Join Date: Jan 2007
Location: Hamburg, Germany
Posts: 5,867
Send a message via ICQ to nicolas-eric Send a message via AIM to nicolas-eric Send a message via MSN to nicolas-eric Send a message via Yahoo to nicolas-eric
Can I remove the drum only by pulling them from the axle after i removed the wheel?

I saw on an old pic from my TJ that there is something like a toothed wheel at teh axle where the ABS sensor is connected. Could that cause the problems when itīs full of mud?

The e-brake cables seem to be ok. Perhaps itīs also a problem with mud on the e-brake shoes.
How can I adjust the e-brake? On my old TJ i had to pull the hand brake lever only 4-5 "clicks" and then it was engaged. On my new TJ i always had to pull the lever 10-12 "clicks".
nicolas-eric is offline   Quote Quick Reply
Old 07-31-2008, 07:01 AM   #4
Jeeper
 
CJ2WRANGLER's Avatar
 
Join Date: Apr 2007
Location: Virginia
Posts: 103
Nico, I recently got my jeep stuck in about 3 feet of clay. I didn't drive long enough to see if I had any brake problems, but I took off all 4 wheels and sprayed them with a power washer. I took off the rear brake drum and power washed each side really well (where most of the mud was at). I have not had a problem since.
__________________
1999 TJ 2.5
Aftermarket Header with Flowmaster
ARB Safari Snorkel with Airaid box
TB spacer/Bored out TB
4" Rough Country Lift
33x12.50 Maxxis Bighorns on 15x8 Cragar Soft 8's
Classic Rock Rear Bumper with Tire Carrier
Custom front bumper
4.88 gears

1998 BMW 328i (Wife's)
Upgraded sound and DVD players

2003 Honda RVT1000R (RC51)
Sako pipes
Power commander
Adjustable steering damper, fender eliminator, led's

2005 Kawasaki Vulcan 500 (Wife's)
CJ2WRANGLER is offline   Quote Quick Reply
Old 07-31-2008, 11:10 AM   #5
MOz
Jeeper
 
MOz's Avatar
 
Join Date: Apr 2007
Location: Poconos
Posts: 2,484
Quote:
Originally Posted by nicolas-eric View Post
Can I remove the drum only by pulling them from the axle after i removed the wheel?

I saw on an old pic from my TJ that there is something like a toothed wheel at teh axle where the ABS sensor is connected. Could that cause the problems when itīs full of mud?

The e-brake cables seem to be ok. Perhaps itīs also a problem with mud on the e-brake shoes.
How can I adjust the e-brake? On my old TJ i had to pull the hand brake lever only 4-5 "clicks" and then it was engaged. On my new TJ i always had to pull the lever 10-12 "clicks".
The rear drums will simply pull off (make sure yuo have the e-brake disengaged).
__________________


It ain't no fun unless you get some of it on you.
MOz is offline   Quote Quick Reply
Old 07-31-2008, 12:06 PM   #6
Jeeper
 
tj1230's Avatar
 
Join Date: Jun 2008
Location: Riverdale, UT
Posts: 151
Just a question here... Doesn't the E-Brake have a cable with nut attached to it for adjustment? This is what I did in my YJ. Pull the cable taught, and then tighten the nut. Don't over tighten. Just check periodically.

Just a thought!
tj1230 is offline   Quote Quick Reply
Old 07-31-2008, 02:23 PM   #7
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
Quote:
Originally Posted by nicolas-eric View Post
I saw on an old pic from my TJ that there is something like a toothed wheel at teh axle where the ABS sensor is connected. Could that cause the problems when itīs full of mud?
Thats a possibility too. The toothed gear on the back of the hub assembly might have rocks or whatever in it giving the sensor false readings.
AzTJ is offline   Quote Quick Reply
Old 07-31-2008, 02:51 PM   #8
Jeeper
 
Join Date: Nov 2006
Location: Chicago, IL
Posts: 8,286
Send a message via AIM to Triple88a Send a message via MSN to Triple88a Send a message via Yahoo to Triple88a Send a message via Skype™ to Triple88a
Nico the drums should just pull out as said above however thats usually not the case because of rust and wear. As brakes are used, the brake shoes wear (or brake pads on disks) but also the drum (or rotor) wears along with it. Just a lot slower. Its common for a drum to form a little edge there that will not allow the drum to come out. What i used was a drum puller and then i banged on the edges with a hammer and it came off. If that doesnt work you will have to shorten the star adjuster screw and close the shoes together.

http://www.mgaguru.com/mgtech/brakes/bt105.htm

Triple88a is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My Clutch Problems and How I Resolved Them linz TJ Tech Forum 6 05-10-2013 07:11 PM
Brake Light Problems? jbone03 TJ General Discussion Forum 10 09-24-2011 12:10 PM
Brake problems...please help!!! swetzel Ohio Jeep Forum 2 10-28-2008 09:28 AM
Brake Problems y0diggy TJ Tech Forum 9 09-30-2007 08:20 PM
Brake problems! Valley Wrangler TJ Tech Forum 22 07-08-2007 04:44 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:51 AM.



JeepŪ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC