Center dash vents not working? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-26-2012, 11:47 AM   #1
Jeeper
 
Join Date: Oct 2012
Location: Redding, Ca
Posts: 126
Center dash vents not working?

I bought a 1997 SE a couple of weeks ago. When I move the top knob from defrost to AC or dash vents the air changes but I do not get air from the center 2 vents. I do get air from the side vents. Are the vent controls vacuum actuated? Do you think just a vacuum line is off or plugged somewhere?

pne123 is offline   Quote Quick Reply
Old 10-26-2012, 12:25 PM   #2
Jeeper
 
lapis_blue's Avatar
 
Join Date: Sep 2012
Posts: 210
Images: 1
More than likely, just pop ur dash off when u get some time an check to mak sure everything is connected and not clogged. My drivers side was clogged and have to clean it out

lapis_blue is offline   Quote Quick Reply
Old 12-28-2012, 03:27 AM   #3
Jeeper
 
duaneduanet's Avatar
 
Join Date: May 2009
Location: Greenville,SC
Posts: 349
Not sure if you fixed the issue. But I fixed mine. It was a cracked vacuum line under the hood near the battery.
__________________
1997 Jeep Wrangler 4.0 5 speed
duaneduanet is offline   Quote Quick Reply
Old 12-28-2012, 07:37 AM   #4
Jeeper
 
Join Date: Nov 2012
Posts: 43
Quote:
Originally Posted by duaneduanet View Post
Not sure if you fixed the issue. But I fixed mine. It was a cracked vacuum line under the hood near the battery.
Duanduanet,
Was it also just the center vents not working for you?
racerboy6996 is offline   Quote Quick Reply
Old 12-28-2012, 12:29 PM   #5
Jeeper
 
duaneduanet's Avatar
 
Join Date: May 2009
Location: Greenville,SC
Posts: 349
Yes from what I remember it was just the center vents.
__________________
1997 Jeep Wrangler 4.0 5 speed
duaneduanet is offline   Quote Quick Reply
Old 12-28-2012, 12:31 PM   #6
Jeeper
 
duaneduanet's Avatar
 
Join Date: May 2009
Location: Greenville,SC
Posts: 349
I replaced all soft vacuum lines for the AC unit under the hood. Cheap insurance and it fixed the problem
__________________
1997 Jeep Wrangler 4.0 5 speed
duaneduanet is offline   Quote Quick Reply
Old 12-28-2012, 12:54 PM   #7
Jeeper
 
Join Date: Nov 2012
Posts: 43
Thanks

racerboy6996 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:59 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC