Check Engine Light 2.4 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-12-2007, 09:28 PM   #1
Registered User
 
NalinMFG's Avatar
 
Join Date: Nov 2006
Location: Evansville, IN
Posts: 940
Send a message via AIM to NalinMFG Send a message via MSN to NalinMFG Send a message via Yahoo to NalinMFG
Question Check Engine Light 2.4

My check engine light has been on for a few weeks. I did the key thing and code 2.4 comes up. (This is the throttle position sensor.) I went to autozone and picked up a new TPL, installed it, and it still idles low w/ the CEL still on... The jeep still tells me code 2.4. I had autozone do their free scanner on it and it came up something totally different with the Evap system. Does my Di-electric greese need to dry, or is my jeep telling me fibs:chair: ?

__________________


NalinMFG.com

TJ 5.25" Speaker Adapters
Facebook Like for a 10% coupon

100% Made in USA
NalinMFG is offline   Quote Quick Reply
Old 07-12-2007, 09:32 PM   #2
Jeeper
 
RIPBiker13's Avatar
 
Join Date: Jul 2007
Location: El Paso
Posts: 3,331
Send a message via Yahoo to RIPBiker13
Did you recently do anything to your exhaust?

__________________
-0lllllll0-


"If I were going to give people one clue as to how to achieve true happiness, it would be this: Find something you would die for, and live for that."
-Unknown

RIPBiker13 is offline   Quote Quick Reply
Old 07-12-2007, 09:34 PM   #3
Registered User
 
NalinMFG's Avatar
 
Join Date: Nov 2006
Location: Evansville, IN
Posts: 940
Send a message via AIM to NalinMFG Send a message via MSN to NalinMFG Send a message via Yahoo to NalinMFG
actually this would have come on shortly after i did mine. i put on a magnaflow cat, flowmaster 40, and a new rear O2 sensor. is that my culpret?
__________________


NalinMFG.com

TJ 5.25" Speaker Adapters
Facebook Like for a 10% coupon

100% Made in USA
NalinMFG is offline   Quote Quick Reply
Old 07-12-2007, 09:40 PM   #4
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
O2 sensors have nothing to do with fuel until the vehicle has warmed up to normal operating temps.

Get some throttle body cleaner and clean out the TPS and IAC.
AzTJ is offline   Quote Quick Reply
Old 07-12-2007, 09:58 PM   #5
Registered User
 
NalinMFG's Avatar
 
Join Date: Nov 2006
Location: Evansville, IN
Posts: 940
Send a message via AIM to NalinMFG Send a message via MSN to NalinMFG Send a message via Yahoo to NalinMFG
clean it out? i just put a brand new one in...:chair:

brainfart- IAC?
__________________


NalinMFG.com

TJ 5.25" Speaker Adapters
Facebook Like for a 10% coupon

100% Made in USA
NalinMFG is offline   Quote Quick Reply
Old 07-12-2007, 10:01 PM   #6
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
Idle Air Control - even though you have a new one doesn't mean that there is some gunk in there.

Is it acting funny at all? Driving strange?

When the light came on, was it not too long after filling up at the gas pump?
AzTJ is offline   Quote Quick Reply
Old 07-12-2007, 10:07 PM   #7
Registered User
 
NalinMFG's Avatar
 
Join Date: Nov 2006
Location: Evansville, IN
Posts: 940
Send a message via AIM to NalinMFG Send a message via MSN to NalinMFG Send a message via Yahoo to NalinMFG
im not sure about filling up. i know ive had my cap screwed on tight if thats whats you were getting to. I believe it used to idle around 1000rpms but now it is as low as 400 and usually as high as 800 (average 500-600). sometime after my foot is off the pedal it will stick at 1100-1200. hesitation coming out of 1st/2ed(sometimes). right now thats all i can think of. my exhaust sounds almost unmuffeled (dont know if that has anything to do with it) flowmaster 40 (may have blown it out?) i just remember that happening around the CEL as well.
__________________


NalinMFG.com

TJ 5.25" Speaker Adapters
Facebook Like for a 10% coupon

100% Made in USA
NalinMFG is offline   Quote Quick Reply
Old 07-12-2007, 10:12 PM   #8
Drives by Braille

WF Supporting Member
 
AzTJ's Avatar
 
Join Date: Dec 2006
Location: For-8-Oh!
Posts: 13,621
Try cleaning it out and see if that helps.
AzTJ is offline   Quote Quick Reply
Old 07-13-2007, 09:34 AM   #9
Jeeper
 
4.0l sahara's Avatar
 
Join Date: Apr 2007
Location: shelton,ct
Posts: 2,228
Take the tb off and clean it well along with the tps and iac. A jeep doesn't idle around 1000rpm it should be around 600.
__________________
99 sahara
4.0/np231/ax15/d30/d35
flowmaster40,hpd30 with aussie locker,currie upper joints,4.88's, lca skids,chromo shafts,vanco brakes,d35 with super 35 and arb locker,re 4.5" springs,currie arms,re front uppers,Re shocks in back,walkerevens shocks up front, Re track bars with currie jj joints,anti rock,ss brake lines,re rear sway bar links,jks 1.25" bl and mml,bfg 35x12.5 km2's,craiger soft 8's,ome steering stabilizer,currie hd steering,rockmen front bumper,emp tank skid,lots more too.
4.0l sahara is offline   Quote Quick Reply
Old 07-13-2007, 09:43 AM   #10
Registered User
 
NalinMFG's Avatar
 
Join Date: Nov 2006
Location: Evansville, IN
Posts: 940
Send a message via AIM to NalinMFG Send a message via MSN to NalinMFG Send a message via Yahoo to NalinMFG
i can just sit there and it fluxuates(sp?) on its own during idle. what product/brand would you recomend for cleaning? i know i need throttle body cleaner, what electrical cleaner would you recomend?
__________________


NalinMFG.com

TJ 5.25" Speaker Adapters
Facebook Like for a 10% coupon

100% Made in USA
NalinMFG is offline   Quote Quick Reply
Old 07-13-2007, 06:48 PM   #11
Jeeper
 
Rawkon's Avatar
 
Join Date: Apr 2005
Location: fullerton/big bear
Posts: 2,061
Send a message via AIM to Rawkon Send a message via MSN to Rawkon
Isnt "2.4" the software version of the comp??? has nothing to do with a tps. if you do the key trick correctly a P000 code will show. If you went to autozone and there saying something is up with your evap system. I would check that. there are several vaccuum lines that come off the manifold and other various places that then go to your evap system.

There is a diagram oof your evap system on the bottom side of the hood. check and make sure all the vaccuum lines are connenced and there are no cracks in them. 9 times out of 10 for me evap systems problems are bad lines that crack and leak not gas caps.

a vacc line thats cracked or fallen off will make your idle jump around.
if you notice a bunch of gunk build up oner the plates of the throttle body i would recomend you sea foam the motor
Rawkon is offline   Quote Quick Reply
Old 07-13-2007, 09:21 PM   #12
Jeeper
 
4.0l sahara's Avatar
 
Join Date: Apr 2007
Location: shelton,ct
Posts: 2,228
Ya now that you say that 2.4 is the software version. Check for vac leaks
__________________
99 sahara
4.0/np231/ax15/d30/d35
flowmaster40,hpd30 with aussie locker,currie upper joints,4.88's, lca skids,chromo shafts,vanco brakes,d35 with super 35 and arb locker,re 4.5" springs,currie arms,re front uppers,Re shocks in back,walkerevens shocks up front, Re track bars with currie jj joints,anti rock,ss brake lines,re rear sway bar links,jks 1.25" bl and mml,bfg 35x12.5 km2's,craiger soft 8's,ome steering stabilizer,currie hd steering,rockmen front bumper,emp tank skid,lots more too.
4.0l sahara is offline   Quote Quick Reply
Old 07-25-2007, 12:37 AM   #13
Registered User
 
NalinMFG's Avatar
 
Join Date: Nov 2006
Location: Evansville, IN
Posts: 940
Send a message via AIM to NalinMFG Send a message via MSN to NalinMFG Send a message via Yahoo to NalinMFG
Talking

well i got it fixed. i cleaned the throttle body plus all the connections as well as checked the hoses, i even ordered a new bored out throttle body ....because none of that worked() i unhooked my battery for 15 mins, hooked it back up, my CEL is off and it idels correctly:chair: I have no idea.
__________________


NalinMFG.com

TJ 5.25" Speaker Adapters
Facebook Like for a 10% coupon

100% Made in USA
NalinMFG is offline   Quote Quick Reply
Old 07-25-2007, 01:34 AM   #14
Jeeper
 
Rawkon's Avatar
 
Join Date: Apr 2005
Location: fullerton/big bear
Posts: 2,061
Send a message via AIM to Rawkon Send a message via MSN to Rawkon
well dont be suprised if it happens again. taking off the battery cable just resets the PCM. hopefully is was just a fluke.

Rawkon is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light gamecock22 TJ General Discussion Forum 21 03-05-2012 02:15 PM
check engine light, tied to 4WD use? frankfletez YJ Tech Forum 2 08-09-2008 12:54 PM
Check Engine Light vin211 TJ Tech Forum 4 04-07-2008 09:12 AM
Idling strange = check engine light? Rubigoddess TJ Tech Forum 6 03-01-2008 12:38 PM
Check engine light 94redwrangler YJ Tech Forum 2 12-19-2007 03:48 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:06 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC