Check engine light after thermostat replacemet - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-25-2012, 04:58 PM   #1
Jeeper
 
29JeepTJ09's Avatar
 
Join Date: Nov 2011
Location: Los Angeles, CA
Posts: 44
Check engine light after thermostat replacemet

Just replaced my t-stat in my 98 4.0. The check engine light came on when I had the temp sensor wire unplugged while burping the system from the temp sensor. I tried unplugging the battery trying to reset it, but it did nothing. Any ideas?

29JeepTJ09 is offline   Quote
Old 09-25-2012, 05:23 PM   #2
Jeeper
 
tallzdatank's Avatar
 
Join Date: Sep 2012
Posts: 1,045
go down to a parts store, many will lend a scan tool out for free, if you can find one, just plug it in and clear the code.

tallzdatank is offline   Quote
Old 09-25-2012, 05:23 PM   #3
Jeeper
 
29JeepTJ09's Avatar
 
Join Date: Nov 2011
Location: Los Angeles, CA
Posts: 44
Quote:
Originally Posted by tallzdatank
go down to a parts store, many will lend a scan tool out for free, if you can find one, just plug it in and clear the code.
Good idea thanks.
29JeepTJ09 is offline   Quote
Old 09-25-2012, 05:47 PM   #4
Jeeper
 
29JeepTJ09's Avatar
 
Join Date: Nov 2011
Location: Los Angeles, CA
Posts: 44
So good ol' autozone said its illegal in CA to check codes now. Whatever. Off to my trusty local shop now.
29JeepTJ09 is offline   Quote
Old 09-25-2012, 05:50 PM   #5
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 36,724
So you got the thermostat properly reconnected and disco'd the battery for 2-3 minutes?
__________________
When you have a choice, buy American.

Jerry Bransford is online now   Quote
Old 09-25-2012, 06:16 PM   #6
Jeeper
 
29JeepTJ09's Avatar
 
Join Date: Nov 2011
Location: Los Angeles, CA
Posts: 44
Quote:
Originally Posted by Jerry Bransford
So you got the thermostat properly reconnected and disco'd the battery for 2-3 minutes?
T-stat is in okay. Only had the battery off for about 30 seconds though, so that is probably why it didn't clear on its own. But anyway my local guy cleared the code for free. Thanks for advice on the battery for future reference.

29JeepTJ09 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 06:33 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC