Climate controls - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-29-2009, 05:22 PM   #1
Jeeper
 
MTabor's Avatar
 
Join Date: Aug 2009
Location: Detroit Suburb
Posts: 30
Exclamation Climate controls

There seemed to be many people with CC issues... so I created this thread just for that issue.

I have just completed repairs on two separate CC issues

1. The blower speed switch only working on the top two settings. This was a pretty easy and straightforward fix, replacing the resistor on the blower motor housing.... about $25

2. The air deflector was not operating. Ours blew air only out of the defrost, and would not change when the selector was moved. This was a big surprise. Initially, I thought the CC panel was the culprit ($100) because of the above problem... the two separate issues had the panel in common. But after replacing it, the problem remained. Was ready to replace the actuator...but did some research on Google first. As it turns out, it was as simple as the vacuum hose coming off of the intake manifold. It just "popped" off... and this was the source of vacuum for the CC panel controls. So, I popped in back on...everything worked as it should.

I consider myself lucky to have such an easy fix, though it took a few days to get both issues corrected. I felt that others might be helped by this discovery, and hopefully you have read this before shelling out a non-refundable $100 for a new CC panel...

MTabor is offline   Quote Quick Reply
Old 08-29-2009, 08:02 PM   #2
Jeeper
 
Hensman's Avatar
 
Join Date: May 2009
Location: Pleasanton, CA
Posts: 322
I just started having your second problem about three days ago. Which line was yours that popped off? The brake booster line?

__________________
2005 TJ Unlimited 4.0 6 speed
LoD expedition series rear bumper/tire carrier, BFG A/T 32x11.5x15, OME 2.5 w/ lj springs
Hensman is offline   Quote Quick Reply
Old 08-29-2009, 08:41 PM   #3
Jeeper
 
MTabor's Avatar
 
Join Date: Aug 2009
Location: Detroit Suburb
Posts: 30
Quote:
Originally Posted by Hensman View Post
I just started having your second problem about three days ago. Which line was yours that popped off? The brake booster line?
Look on the side of the intake manifold, about half way down its length, a little low. You should see 2 or 3 3/8" vacuum lines going to the intake. Actually... if it is the problem... just look for a shiny nipple stick out where the line should be. Good luck, let me know if it helped!

I AM John Galt.
MTabor is offline   Quote Quick Reply
Old 08-29-2009, 08:47 PM   #4
Jeeper
 
coolbreeze's Avatar
 
Join Date: Jul 2009
Location: Redding, Ca
Posts: 869
I have problem #1. Some pictures of the resister and where it is sure would be nice. I have a 2004. Thanks.
__________________
2004 Black X 4.0, auto, 3.73's, soft top 31-10.5-15 Toyo A/T's on 8" Ultra 175's, 2" Teraflex BB.
coolbreeze is offline   Quote Quick Reply
Old 08-29-2009, 09:25 PM   #5
Jeeper
 
MTabor's Avatar
 
Join Date: Aug 2009
Location: Detroit Suburb
Posts: 30
Quote:
Originally Posted by coolbreeze View Post
I have problem #1. Some pictures of the resister and where it is sure would be nice. I have a 2004. Thanks.
Yeah... I was thinking that about the pics, too

you'll need to lie upside down and look up behind the glove box (for lighting...it might help to take glove box out). It might be easier for you if you remove the light down there. You're looking on the side of the blower motor housing for a (2" wide) "flat four" electrical connection. It will have two 5/16" nut screws holding it. I believe there is also a red lock on the connector, as well... should be able to slide off with some effort. Hope this helps. If I find some time and inclination, I'll take a pic and upload it. The part should be at your local dealer, about $20 for the resistor. G/L... let us know if you got it!
__________________
“So you think that money is the root of all evil?” said Francisco d’Anconia.

“Have you ever asked what is the root of money? ... Money is made possible only by the men who produce.... Is this what you consider evil?
MTabor is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Climate control speed knob WSU Tony TJ Tech Forum 26 09-26-2010 03:41 PM
98 TJ, Climate control levers dont return mudslinger150 TJ Tech Forum 2 08-26-2009 03:40 PM
HVAC Controls Left In The "ON" Position BLACKTOOTHGRIN TJ Tech Forum 4 06-16-2009 04:48 AM
Climate Control Problem, only blows out defroster vent Morgan TJ Tech Forum 3 04-21-2008 07:38 PM
climate control knobs michman TJ Tech Forum 2 03-13-2006 04:23 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:31 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC