Clutch Question - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-17-2012, 01:03 PM   #1
Jeeper
 
Rayko's Avatar
 
Join Date: Apr 2009
Location: NJ Badlands
Posts: 901
Question Clutch Question

Ok, I had a new clutch and clutch hydro cylinder put in. I keep on losing the freeplay in the clutch and it grabs right off the floor. I take the cap of the hydro system and pump it a few times and it does improve but after a while I lose it again. Is there air in the system? If so how can I bleed it out? Any help is greatly appreciated.

Rayko is offline   Quote
Old 11-17-2012, 03:02 PM   #2
Jeeper
 
01tj-Bob's Avatar
 
Join Date: Apr 2012
Location: Southern Cali
Posts: 68
Bleed the slave

01tj-Bob is offline   Quote
Old 11-17-2012, 03:46 PM   #3
Jeeper
 
Rayko's Avatar
 
Join Date: Apr 2009
Location: NJ Badlands
Posts: 901
How do I do that?
Rayko is offline   Quote
Old 11-17-2012, 04:32 PM   #4
Jeeper
 
Join Date: Aug 2011
Posts: 19
If it is an external slave not sure what you are working on ,I removed mine and pumped it by hand. Quadratec has instructions on there tech page.
drexel is offline   Quote
Old 11-17-2012, 10:17 PM   #5
Jeeper
 
01tj-Bob's Avatar
 
Join Date: Apr 2012
Location: Southern Cali
Posts: 68
01tj-Bob is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 06:40 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC