Crankshaft/Camshaft Sensors - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-21-2013, 09:08 AM   #1
Newb
 
Join Date: Jul 2013
Posts: 1
Crankshaft/Camshaft Sensors

I have a 98 Jeep Wrangler TJ, 2.5L 4 cyl. For the past few monthst I have been dealing with a frustrating problem. Basically, The engine will not restart when It has been run for a while. I have been sporadically reading codes, p0320, 0340. I replaced the coil, then replaced the fuel pressure regulator because that tested bad. The jeep ran for about 400 miles awesomely, starting and stopping no problems. The engine light came on and it will not restart when hot. Cold starts are no problem. So; Crankshaft, Camshaft, O2 sensors? Computer?

windbiter is offline   Quote
Old 07-21-2013, 09:19 AM   #2
Newb
 
Join Date: Jul 2013
Posts: 2
All jeeps at one time or another are going to have the crank sensor go bad. Symptomatically your problem sounds like a crank sensor. If you can, check if your getting injector pulse. If you are not you probably have a bad crank sensor
Jeepguy45 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:22 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC