Diagnostic Error Codes on 2005 SE 4cyl. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-01-2007, 08:21 PM   #1
Jeeper
 
Join Date: Sep 2005
Location: The Deserts of So. California
Posts: 27
Diagnostic Error Codes on 2005 SE 4cyl.

Ok, Thanks to your guy's help I was able to get the error code. The error code is: P 2074
Like before it was about 100 degrees and I was traveling about 75mph and my TJ jerked and lost power and the engine light went on and then it runs sluggish and bad. The last time it happened kept happening (Nov.06) the dealer couldn't figure out what the problem was so they replaced Oxy. sensors, computer, tighted vaccum hoses and other stuff. Now it's hot and it's doing it again.

__________________
2005 Wrangler SE. 4 cyl. 6 sp.
Bassplunker is offline   Quote Quick Reply
Old 06-02-2007, 02:20 AM   #2
Jack Lives Here!!!

WF Supporting Member
 
1BLKJP's Avatar
 
Join Date: Apr 2005
Location: Phoenix, AZ
Posts: 7,764
Looks like it's a problem with your MAP sensor. Either it's going bad or there something up with the pressure inside your intake.

__________________
Thanks,
Jack Hickman

President - Arizona Off-Highway Vehicle Coalition
Vice-President - ASA4WDC
Arizona Rock Rats
1BLKJP is offline   Quote Quick Reply
Old 06-02-2007, 10:44 AM   #3
Jeeper
 
Join Date: Sep 2005
Location: The Deserts of So. California
Posts: 27
Quote:
Originally Posted by 1BLKJP View Post
Looks like it's a problem with your MAP sensor. Either it's going bad or there something up with the pressure inside your intake.
Well, my invoice from last year says they found the same code: P2074 High flow vaccuum leak, and also says,

"Because of number of visits Called STAR and recommended to drive vehicle with CO-PILOT. Drove 76 miles, no event data. Freeze frame data shows BARO too low. Had like concern that PCM resolved concern. Contacted TECH ADV and was recommended that PCM/TPS/

My parts invoice from then says:
Sensor TH
Sensor MA
Module PO
__________________
2005 Wrangler SE. 4 cyl. 6 sp.
Bassplunker is offline   Quote Quick Reply
Old 06-02-2007, 10:47 AM   #4
Jeeper
 
Join Date: Sep 2005
Location: The Deserts of So. California
Posts: 27
Quote:
Originally Posted by 1BLKJP View Post
Looks like it's a problem with your MAP sensor. Either it's going bad or there something up with the pressure inside your intake.
Well, my invoice from last year says they found the same code: P2074 High flow vaccuum leak, and also says,

"Because of number of visits Called STAR and recommended to drive vehicle with CO-PILOT. Drove 76 miles, no event data. Freeze frame data shows BARO too low. Had like concern that PCM resolved concern. Contacted TECH ADV and was recommended that PCM/TPS/MAP be replaced
My parts invoice from then says:
Sensor TH
Sensor MA
Module PO
__________________
2005 Wrangler SE. 4 cyl. 6 sp.
Bassplunker is offline   Quote Quick Reply
Old 06-02-2007, 03:11 PM   #5
Jeeper

WF Supporting Member
 
chucky cheese's Avatar
 
Join Date: Dec 2006
Location: We eat stuff outa ditches!
Posts: 4,015
It has to be something with 2005 4 banger. I had the exact same problem. It was in the dealer shop 3 times for 3 weeks at a time over a 1 year span. same thing, map sensor, vacume leak,ect.. The last time it went in when i got it back I saw that they changed all the relays in the box on the passenger side under the hood. also I noticed a sticker on the underside of the hood that says chrysler approved modifications done on such a such date before i owned it. The sticker was there but I never noticed it before but I saw that it had written on it that modification was done again on the date I had brought it in the last time. I bought it with 7000 miles on it in Feb 2oo6, it acted up at about 8200 miles, again at 8900 miles again at 9300 miles. since they changed the relays and did whatever the mod. was I haven't had a problem and I now have aprox 15000 miles. Also I never could get the dealer to explain what was done and what the problem is or was, bast***s
__________________
It ain't easy being cheesy:

Sometimes I make decisions like famous people.
George Armstrong Custer "lets go over that hill, I think those are friendly indians!"

Titanic's Captain Smith "What icebergs? Full speed ahead!"
chucky cheese is offline   Quote Quick Reply
Old 06-02-2007, 06:49 PM   #6
Jeeper
 
Join Date: Sep 2005
Location: The Deserts of So. California
Posts: 27
Quote:
Originally Posted by chucky cheese View Post
It has to be something with 2005 4 banger. I had the exact same problem. It was in the dealer shop 3 times for 3 weeks at a time over a 1 year span. same thing, map sensor, vacume leak,ect..
What's strange is it didn't do it for 6 months but as soon as it got over a 100 degrees here it starts acting up again. I'll mention your post to the dealer though. Hopefully it will help. There IS a leftover new Unlimited for a great price at the dealer but it seemed so big.
__________________
2005 Wrangler SE. 4 cyl. 6 sp.
Bassplunker is offline   Quote Quick Reply
Old 06-03-2007, 12:45 AM   #7
Jeeper
 
dwdrums801's Avatar
 
Join Date: Aug 2006
Location: Long Island, NY
Posts: 1,298
my tj makes weird sounds when it gets over 90 here in ny....weird carss
__________________
06 Rubi Unlimited, 3.5" Rubicon Express LA, OME Shocks, Metal Cloak Aluminum Bumper, Warn Winch, Power locks/remote start.
dwdrums801 is offline   Quote Quick Reply
Old 06-13-2007, 05:14 PM   #8
Jeeper
 
Join Date: Sep 2005
Location: The Deserts of So. California
Posts: 27
So I bring it to the dealer again (5x's now) with the engine light on again and show the service writer the error code that's still in memory. They call me two days later and say to come pick it up and bring it back the following week because the Regional Manufacturer Technician will be in to look at it. They call me last night and say to bring it in again so I do. They call my wife today and say to come get it. I call them and ask them if they did anything. They say no, but Chrysler is aware of the problem and they should come out with a fix sometime this year. I say, "So I'm just supposed to drive a car that freaks out every once in a while." They say Yup.
__________________
2005 Wrangler SE. 4 cyl. 6 sp.
Bassplunker is offline   Quote Quick Reply
Old 06-13-2007, 05:18 PM   #9
Jeeper
 
Join Date: Nov 2006
Location: Chicago, IL
Posts: 8,286
Send a message via AIM to Triple88a Send a message via MSN to Triple88a Send a message via Yahoo to Triple88a Send a message via Skype™ to Triple88a
Quote:
Originally Posted by Bassplunker View Post
I call them and ask them if they did anything. They say no...."So I'm just supposed to drive a car that freaks out every once in a while." They say Yup.
Very helpful arent they? I bet you feel so safe in it knowing it may go wild once in a while on its own.. :really:
Triple88a is offline   Quote Quick Reply
Old 02-16-2011, 07:48 PM   #10
Jeeper
 
Join Date: Sep 2005
Location: The Deserts of So. California
Posts: 27
Well, the problem went away for a couple of years but happened again (like usual on a hot day going up a long steep road). Took it to the Jeep dealer and they wanted to do exactly the same thing they had already done that, of course, didn't remedy the situation. I told them that and they said it was misfiring too so I should get a tune-up. $330 for plugs and wires? LOL. Got a Lemon Law Attorney and Chrysler bought it back from me (and reimbursed me for the tune-up, and my Bestop Slider windows and the tow hitch I installed). Luckily when it first happened and I took it in there were only 7k miles on it so they only deducted that from the sales price. Drove it for 5 years for about $800 (plus maintainance). I should have listened to my pledge after my Lemon F-150 4x4 that I'd never buy another car except a Honda or a Toyota. LOL. Now I'll be looking for a short bed Tacoma 4x4 with 4 cyl.

__________________
2005 Wrangler SE. 4 cyl. 6 sp.
Bassplunker is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
4cyl to 6cyl project JuggaloShawn TJ General Discussion Forum 24 09-21-2008 05:27 PM
2005 Wranglers RustyNBeatin2000 TJ General Discussion Forum 5 11-16-2007 11:01 AM



» Featured Product

All times are GMT -5. The time now is 01:12 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC