Driver's side front turn signal dim - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-02-2013, 10:20 PM   #1
Jeeper
 
Join Date: Aug 2013
Posts: 35
Driver's side front turn signal dim

Wow, I googled my symptoms and found a ton of people with dim bulbs and what have you, seems common - mostly related to the hazard switch assembly. My front left turn signal is dim when I have the headlights on. But bright when I switch the hazards on. Whenever the headlights are on, only one of the filaments in the turn signal bulb are lighting up. Have substituted 3 different bulbs with the same result. Grounds behind headlights are intact and grounds behind tail lights are good. Is there a problem with my hazard switch assembly?

saikou is offline   Quote
Old 09-03-2013, 01:02 AM   #2
Jeeper
 
RUBI 4 MY MRS's Avatar
 
Join Date: Feb 2011
Location: California/Nevada
Posts: 1,546
Check the side marker on that side. Is it coming on with the headlights/parking lights? Does it flash with the signals? If not that will cause the problem you describe. In that case check the bulb & the socket.

__________________


'05 Rubi TJ Unlimited
'93 Toyota 4Runner
RUBI 4 MY MRS is offline   Quote
Old 09-03-2013, 03:27 AM   #3
Jeeper
 
Join Date: Aug 2013
Posts: 35
Side marker is lit as it should be, all normal there. Flashes normally. My problem is the front turn signal bulb is only partially lit (dual filament). Only when the flashers or turn signal come on does it illuminate all the way.
saikou is offline   Quote
Old 09-03-2013, 08:59 AM   #4
Supporting Member

WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 7,267
Images: 11
Quote:
Originally Posted by saikou View Post
Side marker is lit as it should be, all normal there. Flashes normally. My problem is the front turn signal bulb is only partially lit (dual filament). Only when the flashers or turn signal come on does it illuminate all the way.
That is the way it's suppose to work. One filiment for the parking/running lights, and the second for the turn signals.
__________________
Dennis
Water Dog is offline   Quote
Old 09-03-2013, 12:38 PM   #5
Jeeper
 
Join Date: Aug 2013
Posts: 35
Ah, ok, so my problem now is the passenger side turn signal is drawing too much power as both filaments are lit on it.

Edit:
Omg, I just checked them and they're both "dim" as should be. Haha, whatever, it's working now. Thanks guys.
saikou is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:02 AM.



Jeep«, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC