Electrical Issue 1997 TJ - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-24-2009, 03:42 PM   #1
Join Date: May 2009
Posts: 4
Electrical Issue 1997 TJ

Installing a radio. The 10 amp radio fuse behind the glove box has no power and cannot find any blown under the hood. Does anyone know which one of the larger fuses feeds the 10 amp radio fuse. I am trying to hook up an after market radio. Thanks.

davis5663 is offline   Quote
Old 07-24-2009, 04:10 PM   #2
Knows a couple things...

WF Supporting Member
Jerry Bransford's Avatar
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 38,496
Is that particular fuse for the switched or unswitched power? Is the key on if it is the switched power lead?

When you have a choice, buy American.

Jerry Bransford is offline   Quote
Old 07-24-2009, 06:50 PM   #3
slf41002's Avatar
Join Date: Feb 2008
Location: Augusta,KY
Posts: 1,163
I think the radio fuse is unswitched/constant hot for radio memory.I am not sure on the Jeep but on most that fuse also runs the horn and a few other things.Check the horn and if all else fails and it is a constant hot just tap into one with a fused lead or run from the batt with a fused lead.
I like for it to shine even thought it is muddy most of the time!
slf41002 is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical issue that keeps getting worse... fourtyoneantz TJ Tech Forum 2 06-28-2010 08:31 PM
Electrical issue with my Jeep-grounding, where to start vijay YJ Tech Forum 23 08-01-2009 08:04 AM
1997 TJ Seat Belt Issue snagg30341 TJ Tech Forum 5 03-23-2008 09:09 PM
Electrical issue macleay YJ Tech Forum 1 02-09-2008 01:40 AM
Weird electrical issue Geeps TJ Tech Forum 5 01-08-2007 02:49 PM

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 08:04 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC