Electrical Issue, Need guidance asap - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-30-2009, 08:26 PM   #1
Jeeper
 
Join Date: Sep 2009
Posts: 19
Electrical Issue, Need guidance asap

I've got an issue with my fiance's Jeep and I don't have a manual or know where to order one to track it down so hopefully you guys could be of some help.




The problem is that the power to the Tachometer, radio, all lights including brake + turn signal lights, was not turning on during start up. At first, it happened only a few times and wasn't that big of an issue because if you turned the car off and started it back up again, the problem would usually go away. The car was cranking fine by the way and would start up every time which made me think it was some kind of relay for the accessories.


But the other day the Jeep was totally dead in a strip mall parking lot. She called me to come pick her up and I snooped around a bit and everything looked ok. The ground was strapped to the block and the battery looked fine (no corrosion around terminals, fairly new, etc)


I jumped in just to see what would happen and it magically started up, but the accessories were totally dead now. It has been dead for the past two days now and its pretty dangerous to drive without brake lights so I made her park it and I gave her a different car to drive.



Thanks for any help you guys could give me in advance. Also, if you could offer a place to buy a manual, I'd appreciate that too.



By the way its a :
1998 Jeep Wrangler Sahra
28,xxx miles on it. Yes, I'm serious, its that cherry. Which is why I want to keep it tip top.



Pics for clicks.



NjTJ is offline   Quote Quick Reply
Old 09-30-2009, 09:15 PM   #2
Jeeper
 
Join Date: Sep 2009
Posts: 19
Quick Update :



To be exact the symptons are as follows.


Key in on position, everything works. Turn signals, brakes, radio, dash, everything.

Car on, Brake lights work, Lights work, Radio does not work, turn signals do not work. Really wierd

NjTJ is offline   Quote Quick Reply
Old 09-30-2009, 09:38 PM   #3
Jeeper
 
csamn2007's Avatar
 
Join Date: Aug 2009
Location: Peterson AFB CO
Posts: 1,911
Send a message via AIM to csamn2007
Ground problem maybe, are you getting power at the fuse box for radio ect? (if you have a multimeter anyways)
__________________
2000 Wrangler Sport
2 in Procomp SL 1 in BL
33 in Procomp MTs
csamn2007 is offline   Quote Quick Reply
Old 10-01-2009, 09:15 PM   #4
Jeeper
 
Join Date: Sep 2009
Posts: 19
Yes, I do get power at the fuse box. This is such a wierd problem because today apparently the car ran fine. Then she told me she smelt a faint burning smell somewhere which worried me.


Are there any vulnerable places on the wiring loom that could be frayed and be shorting each other out or something?

Thanks in advance for any help.
NjTJ is offline   Quote Quick Reply
Old 10-01-2009, 09:17 PM   #5
Jeeper
 
Join Date: Sep 2009
Posts: 19
And just in case, does anyone know of a good Jeep mechanic in Jersey in case I can't track this down?
NjTJ is offline   Quote Quick Reply
Old 10-01-2009, 09:58 PM   #6
Senior Member
 
Join Date: Sep 2008
Posts: 2,775
One other thing to try, mess with the emergency flasher button.

My 2000 had similar issues with some lights (brake/blinker) and I just happened to see if the flashers would work and "using" that switch got things working again.

After that, I cleaned it up and no problems.

Free and easy, hope it works.
stevens243 is offline   Quote Quick Reply
Old 10-03-2009, 07:36 PM   #7
Jeeper
 
HamiltonLJ's Avatar
 
Join Date: Aug 2009
Location: Mercer County N.J.
Posts: 191
What part of Jersey you in. I know of a few places around N.J.

__________________
'04 LJ
33" Trxus MT's
4" Rough Country
Jeep Medic Engine skid
PoisonSpyder RockerKnockers
Rock Krawler UCAs
Schwinn Hand Throttle
Grass Roots Jeep Club President
HamiltonLJ is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 electrical issue? jyeast TJ General Discussion Forum 5 12-15-2011 07:52 PM
Electrical issue that keeps getting worse... fourtyoneantz TJ Tech Forum 2 06-28-2010 08:31 PM
Electrical issue with my Jeep-grounding, where to start vijay YJ Tech Forum 23 08-01-2009 08:04 AM
Electrical issue macleay YJ Tech Forum 1 02-09-2008 01:40 AM
electrical issue khenderson TJ Tech Forum 2 09-15-2005 05:38 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:25 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC