Electrical issues - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-12-2010, 12:00 AM   #1
Jeeper
 
Join Date: Feb 2010
Location: Clarkston
Posts: 107
Electrical issues

I removed my dashboard a few days ago, including the center console and door panels. Ever since then I've noticed some pretty serious electrical issues. When I click back the knob for the lights once to turn the gauge lights on, both turn signal lights and the fog light indicator come on, but nothing else. Also, every gauge goes dead until you turn the jeep off and let it sit for awhile. The actual headlights still work. Without messing with the lights at all, the gauges intermittently go dead, and then eventually come back on while driving it. I also notice that occasionally the tachometer and speedometer freeze for a moment, then jerk back to their correct locations. I poked through the wires that I messed with, mostly the ones behind the radio, A/C controls, etc, but couldn't find anything wrong. Also, the blower motor seems to be dead. When I go to turn the air on, I hear the light hissing noise that goes with it, but the blower doesn't kick on. What the heck did I do? it rained while I had the dashboard off, and I left the window down, but a little water couldn't have caused all these issues, could it? This is a 1997 Wrangler Sport, BTW.

Darth Vader is offline   Quote Quick Reply
Old 08-12-2010, 06:16 AM   #2
Jeeper
 
Join Date: May 2010
Location: Wilmington Delaware
Posts: 28
Remove dash again and use a blow dryer. Yes, water will do that. After they dry out they are ok, at least mine has been.

cosmo05 is offline   Quote Quick Reply
Old 08-12-2010, 08:56 AM   #3
Jeeper
 
Join Date: Feb 2010
Location: Clarkston
Posts: 107
it's been like 5 days since the rain, come to think of it, so I don't think water damage is my problem, but I guess I can give that a shot.
Darth Vader is offline   Quote Quick Reply
Old 08-12-2010, 11:20 PM   #4
Jeeper
 
Join Date: Feb 2010
Location: Clarkston
Posts: 107
OK....I think I've got it. I left the the grounds screwed into the speaker mounts unplugged. 90% certain that all my issues are caused by that. I'm gonna test it tomorrow when I get a chance.
Darth Vader is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Issues mottin44 TJ Tech Forum 2 07-19-2010 06:27 PM
Electrical Issues!!!!!!! jpharry TJ Tech Forum 0 03-17-2010 03:37 PM
Jeep won't start electrical issues. schmutzjt TJ Tech Forum 5 11-04-2009 12:31 PM
electrical issues??? elizabeth YJ Tech Forum 1 08-08-2009 04:47 PM
Having electrical issues Brad W YJ Tech Forum 7 10-01-2008 04:17 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:29 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC