Electrical Nightmare! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-21-2010, 08:57 AM   #1
Jeeper
 
Lowrollin12's Avatar
 
Join Date: Mar 2010
Location: Upstate New York
Posts: 340
Electrical Nightmare!

So 1st I thought i was having issues with the ignition switch when I would have the air bag light come on, No wipers, no radio and no heat. Then it would 1/2 resolve itself and i just wouldnt have wipers and couldnt use the fan on high....

Now the jeep wont start with out a jump and the voltage is around 19 volts on the dash....

I think this could all be from the ignition switch but what do you think?

__________________
MY 3rd TJ and favorite '03 Rubi with 3.5 Rock Krawler Short Arm Kit and RRD 2.0 Shocks, 32' Goodyear MTR's on Dick Cepek Wheels. Viar 450, CB and custom tool/Sub box.

Other rides: 95 Sonoma fully shaved, helium bags/rods for hoppin around, streetbeat rag top, SSBC bigbrake kit.... MORE $$$$ 04 Kawi Ninja zx-6 636 Blazin Orange!
Lowrollin12 is offline   Quote Quick Reply
Old 05-21-2010, 01:37 PM   #2
Jeeper
 
meyers's Avatar
 
Join Date: Apr 2009
Location: Dover, New Hampshire
Posts: 738
The voltage is 19volts at the dash? How are you checking this voltage, the battery is only 12 volts. You may get 14 - 14.5 when charging. But 19 is way out of spec.

meyers is offline   Quote Quick Reply
Old 05-21-2010, 02:44 PM   #3
Jeeper
 
Lowrollin12's Avatar
 
Join Date: Mar 2010
Location: Upstate New York
Posts: 340
No the voltage on the guage cluster is reading that... Im not saying that is what it really is but something is going on...
__________________
MY 3rd TJ and favorite '03 Rubi with 3.5 Rock Krawler Short Arm Kit and RRD 2.0 Shocks, 32' Goodyear MTR's on Dick Cepek Wheels. Viar 450, CB and custom tool/Sub box.

Other rides: 95 Sonoma fully shaved, helium bags/rods for hoppin around, streetbeat rag top, SSBC bigbrake kit.... MORE $$$$ 04 Kawi Ninja zx-6 636 Blazin Orange!
Lowrollin12 is offline   Quote Quick Reply
Old 05-21-2010, 03:39 PM   #4
Jeeper
 
pokey's Avatar
 
Join Date: Feb 2010
Location: backroads of the Mojave
Posts: 1,106
Yes. Bad ignition switch. Classic symptoms. Mine did the same thing.
__________________
__________________________________________
. . . . picking the lines with my twenty-nines . . . .
__________________________________________

'99 sport 4.0 5 speed, top-of-the-line floormats
pokey is offline   Quote Quick Reply
Old 05-22-2010, 05:56 AM   #5
Jeeper
 
Lowrollin12's Avatar
 
Join Date: Mar 2010
Location: Upstate New York
Posts: 340
Quote:
Originally Posted by pokey View Post
Yes. Bad ignition switch. Classic symptoms. Mine did the same thing.
thanks for the help!
__________________
MY 3rd TJ and favorite '03 Rubi with 3.5 Rock Krawler Short Arm Kit and RRD 2.0 Shocks, 32' Goodyear MTR's on Dick Cepek Wheels. Viar 450, CB and custom tool/Sub box.

Other rides: 95 Sonoma fully shaved, helium bags/rods for hoppin around, streetbeat rag top, SSBC bigbrake kit.... MORE $$$$ 04 Kawi Ninja zx-6 636 Blazin Orange!
Lowrollin12 is offline   Quote Quick Reply
Old 05-22-2010, 09:39 AM   #6
Electrical Guy

WF Supporting Member
 
deathphoenix99's Avatar
 
Join Date: Apr 2010
Location: Houston, TX
Posts: 2,619
As for the dash reading 19 volts, dash gauges are known to be horrbly inacurate, I suggest you check the voltage at the battery when the jeep is running, if it is 19 volts, TURN IT OFF IMMEDIATLEY. That high of a voltage will do damage to your electronics. If it is that high, then the voltage regulator on the alternator is bad. I believe it's built into the alternator and is not replaceable, meaning you will have to replace the alternator.

deathphoenix99 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Calling all electrical experts out there popatop YJ Tech Forum 14 11-07-2011 07:43 AM
2010 Sahara Unlimited Electrical Ghosts VinceG JK General Discussion Forum 1 03-18-2010 08:38 AM
Fuel Pump or Electrical Problem? JumpinJack95 YJ Tech Forum 5 10-19-2009 09:48 AM
Electrical Problem Help popatop YJ Tech Forum 2 09-07-2008 01:53 PM
jeep stalled, no electrical brandonpaul YJ Tech Forum 2 02-24-2008 03:56 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:51 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC