Electrical problem? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-18-2010, 06:35 AM   #1
Join Date: Oct 2006
Posts: 3
Electrical problem?

Have 2000 Sport 4.0L. Out of nowhere my battery (1 year old)will not hold a charge at all. Drive for 30 minutes, shut if off and it has nothing. Not even a dome light. Anyone?

joez11 is offline   Quote
Old 03-18-2010, 06:52 AM   #2
I am JD and it's My Dream

WF Supporting Member
::WF Administrator::
JDsDream's Avatar
Join Date: Jan 2009
Location: The Peach State
Posts: 28,069
Cheapest first. Check your battery cables and connections. Clean connectors and terminals with a wire brush to remove any and all corrosion. Any amount can cause these symptoms. Make sure that the connections are really tight, You should not be able to twist them at all once connected.

The kind of woman that when my feet hit the floor each morning the devil says "Oh Crap, She's up!"

To All Of Our Forum Veterans and Active Service Members.
Our Debt To You Is Greater Than We Could Ever Repay.
Thank You

Become a Supporting Member!
JDsDream is online now   Quote
Old 03-18-2010, 08:29 AM   #3
Join Date: Oct 2006
Posts: 3
Yep. ground cable to the block. Back in business!
joez11 is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
fuel or electrical problem?? epop2357 YJ Tech Forum 7 03-24-2011 11:04 AM
Fuel Pump or Electrical Problem? JumpinJack95 YJ Tech Forum 5 10-19-2009 09:48 AM
electrical problem??!! YJ93 YJ Tech Forum 5 12-18-2006 11:18 AM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 12:36 AM

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:39 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC