Electrical Problem - Flasher Module - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-18-2007, 10:33 AM   #1
Jeeper
 
Unlimited's Avatar
 
Join Date: Aug 2005
Location: Gone.... and most likely forgotten.
Posts: 3,044
Electrical Problem - Flasher Module

I'm hoping that someone here can give me an idea of what happened and how I can fix it. (I have a 2004 LJ)

Here's what I did: I replaced my front running lights / flashers with LED bulbs and had the fast flashing problem. I put the stock bulbs back in and went to AutoZone and got an EP-27 flasher module. I removed the stock flasher module from the steering column and installed the EP-27 module. I hit the Emergency flasher button to test it and all I got was a buzzing noise for a few seconds. I replaced the OEM module and now I get nothing from the turn signals, emergency flashers, or brake lights. I've checked the turn signal fuse (#13) and the brake light fuse (#2) and both are Ok.

What am I missing here? Is there a fuse somewhere that may have blown? The fact that the EP-27 buzzed for a few seconds and then quit leads me to believe that it may have been a fuse.

Any help would be greatly appreciated, thanks in advance for your replies.

Unlimited is offline   Quote Quick Reply
Old 03-18-2007, 01:42 PM   #2
Jeeper
 
Unlimited's Avatar
 
Join Date: Aug 2005
Location: Gone.... and most likely forgotten.
Posts: 3,044
Problem Update:

Ok, so I started yanking every fuse I could find and checking them with a multimeter. I found a 20amp fuse in the box in the engine compartment that was bad. The legend labels this fuse as MSFW (27). I replaced it and now I have my lights back. So, current problem solved. Any ideas what caused it?

Unlimited is offline   Quote Quick Reply
Old 03-18-2007, 10:03 PM   #3
Jeeper
 
Join Date: Feb 2007
Location: Wisconsin
Posts: 688
Did you retry the other flasher and bulbs?

C.
jp'rs_peep'rs is offline   Quote Quick Reply
Old 03-18-2007, 10:04 PM   #4
Jeeper
 
Join Date: Feb 2007
Location: Wisconsin
Posts: 688
The led's.

C.
jp'rs_peep'rs is offline   Quote Quick Reply
Old 03-18-2007, 10:32 PM   #5
Jeeper
 
Unlimited's Avatar
 
Join Date: Aug 2005
Location: Gone.... and most likely forgotten.
Posts: 3,044
No. I found out that the problem is the flasher module. I need to get an EP-26. The EP-27 that Autozone claimed was the correct replacement flasher has a history of blowing fuses.
Unlimited is offline   Quote Quick Reply
Old 03-19-2007, 07:26 PM   #6
Jeeper
 
crj101's Avatar
 
Join Date: Feb 2007
Location: Scottsville, Kentucky
Posts: 179
The one thing you did wrong was Autozone.

crj101 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
electrical problem...help!!! evas98tj TJ Tech Forum 3 10-10-2008 10:18 PM
Electrical Problem Help popatop YJ Tech Forum 2 09-07-2008 01:53 PM
Weird flasher problem... GrnTJ TJ General Discussion Forum 4 08-11-2007 12:00 PM
electrical problem??!! YJ93 YJ Tech Forum 5 12-18-2006 11:18 AM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:28 AM.



Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC