electrical problem...help!!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-08-2008, 01:26 AM   #1
Newb
 
Join Date: Oct 2008
Posts: 2
Unhappy electrical problem...help!!!

hey guys,

lately i have an electrical problem and i don't know what causing it.... my gauges in my instrument cluster some times shuts down while i'm driving but it doesn't affect running..... the jeep still runs fine while the gauges are shut down while i'm driving and then, it comes back on again after a few minutes.... i thought it was the battery because it won't start one day....after replacing it i thought it fix the problem but i guess not.... so...if any of you guys can tell me what seems to be the problem...it will be great.

evas98tj is offline   Quote Quick Reply
Old 10-08-2008, 02:09 AM   #2
Jeeper
 
Rawkon's Avatar
 
Join Date: Apr 2005
Location: fullerton/big bear
Posts: 2,002
Send a message via AIM to Rawkon Send a message via MSN to Rawkon
sounds like a loose connector behind the bezel

Rawkon is offline   Quote Quick Reply
Old 10-10-2008, 09:41 PM   #3
Newb
 
Join Date: Oct 2008
Posts: 2
thnx man.....i'll pull it out and check it....
evas98tj is offline   Quote Quick Reply
Old 10-10-2008, 10:18 PM   #4
Jeeper
 
Join Date: Nov 2006
Location: Chicago, IL
Posts: 8,286
Send a message via AIM to Triple88a Send a message via MSN to Triple88a Send a message via Yahoo to Triple88a Send a message via Skype™ to Triple88a
2x ^^ Dont forget to spread some electric grease on the connector when plugging it back in.
Triple88a is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
2000 TJ Electrical Problem Dennis G TJ General Discussion Forum 14 03-01-2012 03:30 PM
Electrical Problem Help popatop YJ Tech Forum 2 09-07-2008 01:53 PM
electrical problem??!! YJ93 YJ Tech Forum 5 12-18-2006 11:18 AM
electrical problem stu TJ Tech Forum 5 01-30-2006 12:37 AM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:11 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC