Electrical Problems? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-11-2013, 06:40 PM   #1
Jeeper
 
CommissionerGordon's Avatar
 
Join Date: Jun 2013
Location: San Antonio
Posts: 64
Electrical Problems?

So today I went to drive my jeep and when I started it the airbag light came on and wouldn't go off. Also, while I had the jeep running my blinkers and windshield wipers wouldn't work. Does anybody know why this would happen or what I could do to fix it?

Thanks!!

__________________
Keep Calm and Chive On!
CommissionerGordon is offline   Quote
Old 06-11-2013, 07:03 PM   #2
Commercial Member

5-Year WF Supporting Member
 
Big Sarge's Avatar
 
Join Date: Dec 2012
Location: Chester Virginia
Posts: 4,829
Quote:
Originally Posted by CommissionerGordon View Post
So today I went to drive my jeep and when I started it the airbag light came on and wouldn't go off. Also, while I had the jeep running my blinkers and windshield wipers wouldn't work. Does anybody know why this would happen or what I could do to fix it?

Thanks!!
Probably the clock spring. Hope that helps you out.

__________________
click the link below to view my Custom pool ball shift Knobs
http://www.wranglerforum.com/f37/custom-camo-pool-ball-shifters-224388.html

NEW AUTOMATIC TJ SHIFT KNOB AVAILABLE at this link

http://www.wranglerforum.com/f37/aut...-new-post.html

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)
Big Sarge is offline   Quote
Old 06-11-2013, 08:35 PM   #3
Jeeper
 
MOTO X TJ's Avatar
 
Join Date: Nov 2011
Location: st louis
Posts: 61
X2 Check the horn too....if its out, I would imagine it is the clock spring.
__________________
2005 LJ
1997 TJ
MOTO X TJ is offline   Quote
Old 06-19-2013, 07:44 AM   #4
Jeeper
 
CommissionerGordon's Avatar
 
Join Date: Jun 2013
Location: San Antonio
Posts: 64
Quote:
Originally Posted by MOTO X TJ View Post
X2 Check the horn too....if its out, I would imagine it is the clock spring.
Everything has been fine up until the past few days. However, I noticed it only happens in the mornings. If I go a tart it during the day it's perfectly fine but in the morning is when it messes up constantly.
__________________
Keep Calm and Chive On!
CommissionerGordon is offline   Quote
Old 06-19-2013, 10:24 AM   #5
Jeeper
 
Wattapunk's Avatar
 
Join Date: Mar 2012
Location: North TX
Posts: 2,276
Usually clockspring issues would involve the airbag light on along with no horn. So if your horn is out, I would look into the clockspring but if not then I am more incline to think you have a faulty ignition switch since you are getting intermittin no power to the wipers and turn signals. I would get a multitester and check the voltage at the ignition switch in various positions. Try jiggling the switch next time the issue occurs.
Wattapunk is offline   Quote
Old 06-19-2013, 10:39 AM   #6
Commercial Member

5-Year WF Supporting Member
 
Big Sarge's Avatar
 
Join Date: Dec 2012
Location: Chester Virginia
Posts: 4,829
Quote:
Originally Posted by Wattapunk View Post
Usually clockspring issues would involve the airbag light on along with no horn. So if your horn is out, I would look into the clockspring but if not then I am more incline to think you have a faulty ignition switch since you are getting intermittin no power to the wipers and turn signals. I would get a multitester and check the voltage at the ignition switch in various positions. Try jiggling the switch next time the issue occurs.
Original post Had complaints of illuminated airbag light as well
__________________
click the link below to view my Custom pool ball shift Knobs
http://www.wranglerforum.com/f37/custom-camo-pool-ball-shifters-224388.html

NEW AUTOMATIC TJ SHIFT KNOB AVAILABLE at this link

http://www.wranglerforum.com/f37/aut...-new-post.html

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)
Big Sarge is offline   Quote
Old 07-18-2013, 06:55 PM   #7
Jeeper
 
JeepGirl94's Avatar
 
Join Date: May 2013
Location: Hagerstown, MD
Posts: 309
Sorry to hijack the thread. But we just bought a 97 wrangler Wednesday and the horn does not work and the air bag light is on. The PO or dealership installed a button on the dash for the horn which is a big pita. What is a clockspring and where is it located? Thanks!
JeepGirl94 is offline   Quote
Old 07-18-2013, 07:13 PM   #8
Commercial Member

5-Year WF Supporting Member
 
Big Sarge's Avatar
 
Join Date: Dec 2012
Location: Chester Virginia
Posts: 4,829
Quote:
Originally Posted by JeepGirl94 View Post
Sorry to hijack the thread. But we just bought a 97 wrangler Wednesday and the horn does not work and the air bag light is on. The PO or dealership installed a button on the dash for the horn which is a big pita. What is a clockspring and where is it located? Thanks!
Here ya go

http://www.wranglerforum.com/f5/airb...ml#post1267523
__________________
click the link below to view my Custom pool ball shift Knobs
http://www.wranglerforum.com/f37/custom-camo-pool-ball-shifters-224388.html

NEW AUTOMATIC TJ SHIFT KNOB AVAILABLE at this link

http://www.wranglerforum.com/f37/aut...-new-post.html

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)
Big Sarge is offline   Quote
Old 07-18-2013, 07:20 PM   #9
Jeeper
 
JeepGirl94's Avatar
 
Join Date: May 2013
Location: Hagerstown, MD
Posts: 309
Thanks
JeepGirl94 is offline   Quote
Old 07-18-2013, 07:49 PM   #10
Commercial Member

5-Year WF Supporting Member
 
Big Sarge's Avatar
 
Join Date: Dec 2012
Location: Chester Virginia
Posts: 4,829
Quote:
Originally Posted by JeepGirl94 View Post
Thanks
You bet ya!
__________________
click the link below to view my Custom pool ball shift Knobs
http://www.wranglerforum.com/f37/custom-camo-pool-ball-shifters-224388.html

NEW AUTOMATIC TJ SHIFT KNOB AVAILABLE at this link

http://www.wranglerforum.com/f37/aut...-new-post.html

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)
Big Sarge is offline   Quote
Old 07-20-2013, 06:05 PM   #11
Newb
 
Maury Moseley's Avatar
 
Join Date: Jul 2013
Location: Richmond Texas
Posts: 3
Ok, i just purchased a 2000 TJ, within a few miles, i get this...........
Air bag light, brake light stuck on....radio out..... And when i put in clutch completely i get a grinding noise that sounds like starter engaging, but only when clutch depressed fully, let it out some and that noise stops.........i am stumped!
Maury Moseley is offline   Quote
Old 07-20-2013, 07:50 PM   #12
Supporting Member

5-Year WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 8,041
Quote:
Originally Posted by Maury Moseley View Post
Ok, i just purchased a 2000 TJ, within a few miles, i get this...........
Air bag light, brake light stuck on....radio out..... And when i put in clutch completely i get a grinding noise that sounds like starter engaging, but only when clutch depressed fully, let it out some and that noise stops.........i am stumped!
If you bought it from a dealer, try taking it back and get them to fix it...! The clutch noise is likely the throw bearing = pulling the transmission and replacing the clutch. The brake light indicates (possibly) that only half your brakes are working, front or back, and the air bag light could be the clock spring (as above) or some other malfunction.
__________________
Dennis
Water Dog is offline   Quote
Old 07-20-2013, 08:07 PM   #13
Newb
 
Maury Moseley's Avatar
 
Join Date: Jul 2013
Location: Richmond Texas
Posts: 3
Quote:
Originally Posted by Water Dog View Post

If you bought it from a dealer, try taking it back and get them to fix it...! The clutch noise is likely the throw bearing = pulling the transmission and replacing the clutch. The brake light indicates (possibly) that only half your brakes are working, front or back, and the air bag light could be the clock spring (as above) or some other malfunction.
The funny thing is, when i turn off jeep and it cools off, all of the symptoms go away......until its driven for enough time for it to heat up...........
Maury Moseley is offline   Quote
Old 07-20-2013, 10:52 PM   #14
Jeeper
 
Join Date: Sep 2009
Location: Rapid City, SD
Posts: 22
Quote:
Originally Posted by CommissionerGordon View Post
So today I went to drive my jeep and when I started it the airbag light came on and wouldn't go off. Also, while I had the jeep running my blinkers and windshield wipers wouldn't work. Does anybody know why this would happen or what I could do to fix it?

Thanks!!

Another way to tell if it's the clockspring, is if you have cruise control and it also is not working. I have a bad clockspring I am going to replace in my 99 TJ, and the horn and cruise don't work. The airbag light also stays on all the time.
dakotaTJ is offline   Quote
Old 08-02-2013, 08:32 PM   #15
Jeeper
 
blade4804's Avatar
 
Join Date: Jul 2013
Location: Euless, TX
Posts: 267
Thread jack... I noticed my airbag light come on and off, radio works fine, I didn't check wipers/horn yet. Howler while the airbag light is on the speedo and odometer drop to 0. Is this also clock spring?

__________________
1999 Jeep Wrangler Sport 4.0 6 Cyl Manual
4" ProComp Shortarm lift with ES3000 shocks
Aussie Front D30 automatic locker
SmittyBilt SRC Front Bumper
Quadratec 9000lb Winch 100ft line
33x12.5x15 Goodyear Duratracs
blade4804 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:28 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC