electrical problems - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-02-2010, 10:56 AM   #1
Jeeper
 
Wayoflife's Avatar
 
Join Date: Mar 2010
Location: Tallahassee, FL
Posts: 58
electrical problems

Ok, so this started happening recently but, my turn signals flash rapidly like they are dead but the bulbs are fine...and one time i was pushing on the brakes and my headlights were going on and off, any ideas what the problem could be?

__________________
1998 TJ wrangler
---------------------
5.5" Procomp Lift
35x13.5x 15 Toyo M/t's
exhaust, headers, all the other good stuff!
Wayoflife is offline   Quote
Old 05-03-2010, 12:11 PM   #2
Jeeper
 
Wayoflife's Avatar
 
Join Date: Mar 2010
Location: Tallahassee, FL
Posts: 58
anyone?

__________________
1998 TJ wrangler
---------------------
5.5" Procomp Lift
35x13.5x 15 Toyo M/t's
exhaust, headers, all the other good stuff!
Wayoflife is offline   Quote
Old 05-03-2010, 12:20 PM   #3
I Need A Cigarette

WF Supporting Member
 
Sf_Kilo's Avatar
 
Join Date: Apr 2010
Location: Bethel Park, PA
Posts: 514
Dead battery ???? charging system issue????? did you check both of these?
Sf_Kilo is offline   Quote
Old 05-03-2010, 12:30 PM   #4
Founder, ThumbJeeps

WF Supporting Member
 
sevenservices's Avatar
 
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 3,952
the connectors on the back of my headlights do that sometimes, they'll just stop working. I need to wiggle the connector and push it back up tight onto the bulb and they're fine. Unplug and re-plug in all your connections at each light. You may find one or two to be corroded a bit. They can be replaced or cleaned, depends how bad they are. I use a small piece of sandpaper folded to slide in and out of each connection, then sand the leads and reseat everything.
__________________
-Chris
Founder, ThumbJeeps


1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 4" RC (33x12.5) (15x8) 3:54 Gears
sevenservices is offline   Quote
Old 05-03-2010, 12:31 PM   #5
Founder, ThumbJeeps

WF Supporting Member
 
sevenservices's Avatar
 
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 3,952
oh also, with the brakes shorting your headlights, you may have a bad seal and water is bridging the connections in the socket. Was it rainy??? or was it just washed??? After re-seating the connections give 'em a quick spray of silicon to help keep the moisture away.
__________________
-Chris
Founder, ThumbJeeps


1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 4" RC (33x12.5) (15x8) 3:54 Gears
sevenservices is offline   Quote
Old 05-03-2010, 04:10 PM   #6
Jeeper
 
Wayoflife's Avatar
 
Join Date: Mar 2010
Location: Tallahassee, FL
Posts: 58
ya it just rained and I also washed it 2 days ago, im going to check all the grounds and connections to see whats up, i also will be sealing all the connections just to be careful.
__________________
1998 TJ wrangler
---------------------
5.5" Procomp Lift
35x13.5x 15 Toyo M/t's
exhaust, headers, all the other good stuff!
Wayoflife is offline   Quote
Old 05-05-2010, 08:58 PM   #7
Jeeper
 
Wayoflife's Avatar
 
Join Date: Mar 2010
Location: Tallahassee, FL
Posts: 58
still no luck

__________________
1998 TJ wrangler
---------------------
5.5" Procomp Lift
35x13.5x 15 Toyo M/t's
exhaust, headers, all the other good stuff!
Wayoflife is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
95 Wrangler Electrical Problems BadAzReb75 YJ Tech Forum 3 12-21-2008 05:59 PM
Electrical Problems? Twitch415 TJ Tech Forum 16 11-12-2008 08:58 AM
Electrical problems lawdog84 TJ Tech Forum 2 08-01-2008 06:02 AM
electrical problems dash spanner659 TJ Tech Forum 0 12-03-2007 10:59 AM
90 Electrical Problems ericchurchflw YJ Tech Forum 4 04-15-2007 01:49 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 10:37 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC