Electrical question for a 99 - won't turn over - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-12-2006, 11:19 AM   #1
Join Date: Jul 2005
Location: MN
Posts: 10
Electrical question for a 99 - won't turn over

I have a 1999 Wrangler Sport & sometimes it won't turn over.
I had an electrical diagnostic test done on it & the results were all good. The alternator is putting out what it is supposed to, and the battery has no dead cells (and is only about 1 1/2 years old - Sears die hard). What do you think could be the problem?

When I turn the key, I get full guages and everything electrical works, but the starter won't turn. Almost like it thinks that I don't have the clutch pushed in. Then I just have to give it a bit of push with my left leg out the door and then usually she just turns right over (with the key, I don't even have to pop the clutch). I am initially inclined to think that I'm losing my ground on the starter, but I wanted to ask you all before I start to tear it all apart. The belts are tight, fluids are good, no sensors are tripped, etc.

Any ideas?



Master Shake is offline   Quote
Old 03-12-2006, 11:57 AM   #2
Knows a couple things...

WF Supporting Member
Jerry Bransford's Avatar
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 38,493
Take both battery connections off, clean them, then retighten them. Such problems are most often caused by nothing more than a loose, dirty, or corroded battery connection.

When you have a choice, buy American.

Jerry Bransford is online now   Quote
Old 03-12-2006, 02:31 PM   #3
Join Date: Jul 2005
Location: MN
Posts: 10
I'll give it a shot right now.

Master Shake is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signals don't turn off jonbugh TJ Tech Forum 19 12-28-2014 01:16 PM
Weird Turn Signal Issue toddyfresh TJ Tech Forum 0 09-03-2008 08:31 PM
electrical problem??!! YJ93 YJ Tech Forum 5 12-18-2006 12:18 PM
Two Part Electrical Question SolLess TJ Tech Forum 1 09-08-2005 10:59 PM

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:34 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC