Electrical Surge, Cruise Control, Auto Speed Sensor - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today



Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-11-2009, 08:17 PM
Thread Starter
  #1
Newb
 
Join Date: Jun 2009
Posts: 1
diegojones is on a distinguished road
Electrical Surge, Cruise Control, Auto Speed Sensor

I have a 2002 Wrangler Sport. About 6 months ago I developed a problem and it has been in the shop 3 times for the same thing.

The problem starts with the cruise control going out. A day or two later the check engine light will come on (Auto Speed Sensor I think it was) about a day after that it will surge like the fuel filter is clogged, a vacuum leak, or I don't know what. Only one day did it die at every single stop. I'll start it and the RPM will go to 2000 and then drop to 500.

The first shop just replaced a fuse and that lasted about a week. The second shop replaced the computer and the throttle sensor which also lasted about a week. I took it back and they soldered two connections instead of using the butt connectors. That lasted about 24 hours.

The last time they test drove it for 2 days (I think they were joy riding) with no problems.

Additional info:
I live on the beach so I'm sure saltwater plays a factor. I always wash it after a beach excursion, but it is in the air.

The airbag light is on. I can't remember what they said the problem was other than it would be $500+ to fix it.

I do live on the beach so the top is down all the time and it has rained in the Jeep.

All input is welcome! I love my Wrangler and am not in a financial position right now to buy a new one.

Thank you in advance.
diegojones is offline   Quote
Reply

Tags
cruise , electric , fuse , short , voltage

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
first time on the beach 08fun JK General Discussion Forum 33 08-03-2011 11:06 AM
No spark!!! Asains YJ Tech Forum 3 05-26-2009 06:10 PM
Speed Pulse Sensor?????? no_limits_jeep TJ Tech Forum 3 02-08-2009 08:54 PM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 12:36 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 03:16 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC
« Back

Enter your email address:

Delivered by FeedBurner