Electrical Surge, Cruise Control, Auto Speed Sensor - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-11-2009, 09:17 PM   #1
Newb
 
Join Date: Jun 2009
Posts: 1
Electrical Surge, Cruise Control, Auto Speed Sensor

I have a 2002 Wrangler Sport. About 6 months ago I developed a problem and it has been in the shop 3 times for the same thing.

The problem starts with the cruise control going out. A day or two later the check engine light will come on (Auto Speed Sensor I think it was) about a day after that it will surge like the fuel filter is clogged, a vacuum leak, or I don't know what. Only one day did it die at every single stop. I'll start it and the RPM will go to 2000 and then drop to 500.

The first shop just replaced a fuse and that lasted about a week. The second shop replaced the computer and the throttle sensor which also lasted about a week. I took it back and they soldered two connections instead of using the butt connectors. That lasted about 24 hours.

The last time they test drove it for 2 days (I think they were joy riding) with no problems.

Additional info:
I live on the beach so I'm sure saltwater plays a factor. I always wash it after a beach excursion, but it is in the air.

The airbag light is on. I can't remember what they said the problem was other than it would be $500+ to fix it.

I do live on the beach so the top is down all the time and it has rained in the Jeep.

All input is welcome! I love my Wrangler and am not in a financial position right now to buy a new one.

Thank you in advance.

diegojones is offline   Quote Quick Reply
Reply

Tags
cruise , electric , fuse , short , voltage

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 01:05 PM
first time on the beach 08fun JK General Discussion Forum 33 08-03-2011 12:06 PM
No spark!!! Asains YJ Tech Forum 3 05-26-2009 07:10 PM
Speed Pulse Sensor?????? no_limits_jeep TJ Tech Forum 3 02-08-2009 09:54 PM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 01:36 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:34 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC