Emissions Evaporator Canister Bad ??? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-04-2012, 05:09 PM   #1
Newb
 
Join Date: Dec 2012
Location: New Port Richey, Florida
Posts: 12
Emissions Evaporator Canister Bad ???

Came up with another question for you all. I had the check engine light come on.. Auto Zone tells me it's a PO441 code.. I replaced the fuel cap, and while changing the purge solenoid I found Charcoal in it. Does the canister go bad ? Or should I just put the new solenoid in and go for it ? I could blow through the old solenoid and can't with the new one. I'm thinking it's bad..

Fl Crayfish is offline   Quote Quick Reply
Old 12-04-2012, 08:14 PM   #2
Jeeper
 
jgorm's Avatar
 
Join Date: May 2010
Location: San Diego
Posts: 1,685
It could be the solenoid, but its possible that the canister could be bad too. I'd start with the solenoid first, but it shouldn't have charcoal in it.

__________________
my 06 LJ rubicon
2.5" SL, 1" BL, DIY highline, 35s with double beadlocks.
jgorm is online now   Quote Quick Reply
Old 12-04-2012, 09:13 PM   #3
Newb
 
Join Date: Dec 2012
Location: New Port Richey, Florida
Posts: 12
Quote:
Originally Posted by jgorm View Post
It could be the solenoid, but its possible that the canister could be bad too. I'd start with the solenoid first, but it shouldn't have charcoal in it.
Yea, That's what I thought. I had charcoal in the lines, and in the solenoid. Is there a way to test the canister to see if it's bad ?
Fl Crayfish is offline   Quote Quick Reply
Old 12-05-2012, 09:00 AM   #4
Jeeper
 
jgorm's Avatar
 
Join Date: May 2010
Location: San Diego
Posts: 1,685
You could pressure test it at <10 psi and see if there are cracks.
__________________
my 06 LJ rubicon
2.5" SL, 1" BL, DIY highline, 35s with double beadlocks.
jgorm is online now   Quote Quick Reply
Old 12-05-2012, 11:37 AM   #5
Jeeper
 
Join Date: Jun 2012
Location: jacksonville
Posts: 15
youve got a bad canister as well. i work for a jeep dealer, ran into this before. replace the sol. and the canister, blow out as many evap lines as possable. this can happen from saturating the canister by "topping off" the tank after the gas handle has clicked off. it comes apart and charcoal goes everywhere
alex1184 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:27 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC