engine light stopped working - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-22-2006, 07:03 PM   #1
Jeeper
 
mrbigjeep's Avatar
 
Join Date: Apr 2006
Posts: 4,288
engine light stopped working

well of course this isn't a huge problem but i would like to fix it as i do not like anything broken on my jeep...but most cars don't even have an engine light for when you open the hood so its not a huge deal...but anyway the engine light under the hood stopped working so when i open the hood the light doesn't come on anymore...do you think water got in there or is the connection just loose?

mrbigjeep is offline   Quote Quick Reply
Old 09-22-2006, 07:36 PM   #2
Pushy, Loudmouthed, and Ballsy
 
Dare2BSquare's Avatar
 
Join Date: Jul 2006
Location: Driving Around Arkansas In My Black XJ
Posts: 6,177
Did you check the bulb? Not trying to be smart, but you didn't mention it. A lot of those lights have a mercury switch in them which works when the hood is raised. Sometimes the bracket on the light gets a little bent and the mercury doesn't flow to complete the circuit. Try bending the bracket a little and see if it works.

__________________
99 XJ Sport
4.0l
AW4
NP231
d30/C8.25
3" Skyjacker lift
31 x 10.50 General Grabbers


http://i66.photobucket.com/albums/h2...are/TMLogo.gif Are all fishermen liars, or do only liars fish?
Dare2BSquare is offline   Quote Quick Reply
Old 09-22-2006, 07:42 PM   #3
Jeeper
 
mrbigjeep's Avatar
 
Join Date: Apr 2006
Posts: 4,288
i went out there to take a look at the light and i didn't see the bracket that you are talking about
mrbigjeep is offline   Quote Quick Reply
Old 09-22-2006, 09:05 PM   #4
Jeeper
 
amerijeep's Avatar
 
Join Date: Apr 2005
Location: Mississippi.
Posts: 3,951
Mercury? Forgive me, but what does mercury have to do with it?
__________________
To all who serve, Thank You.
amerijeep is offline   Quote Quick Reply
Old 09-22-2006, 10:09 PM   #5
Jeeper
 
Texapple's Avatar
 
Join Date: Nov 2005
Location: New Jersey
Posts: 2,617
Quote:
Originally Posted by Dare2BSquare
Did you check the bulb? Not trying to be smart, but you didn't mention it. A lot of those lights have a mercury switch in them which works when the hood is raised. Sometimes the bracket on the light gets a little bent and the mercury doesn't flow to complete the circuit. Try bending the bracket a little and see if it works.


was going to ask that, but knew someone else would do it!
__________________
got rid of the husband.....bought another Jeep

my new spotter
Texapple is offline   Quote Quick Reply
Old 09-22-2006, 10:14 PM   #6
Pushy, Loudmouthed, and Ballsy
 
Dare2BSquare's Avatar
 
Join Date: Jul 2006
Location: Driving Around Arkansas In My Black XJ
Posts: 6,177
Quote:
Originally Posted by amerijeep
Mercury? Forgive me, but what does mercury have to do with it?
Guess that is probably not applicable to a TJ. It's the way older under hood courtesy lights worked. Just like the old mercury thermostats in your house. I know even on my old 89 Blazer the switch was that way. If you raised the hood farther it would come on, but when you put the rod in to hold up the hood it would go out. All you had to do was bend the bracket a little to get it to stay on.
__________________
99 XJ Sport
4.0l
AW4
NP231
d30/C8.25
3" Skyjacker lift
31 x 10.50 General Grabbers


http://i66.photobucket.com/albums/h2...are/TMLogo.gif Are all fishermen liars, or do only liars fish?
Dare2BSquare is offline   Quote Quick Reply
Old 09-22-2006, 10:28 PM   #7
Jeeper
 
amerijeep's Avatar
 
Join Date: Apr 2005
Location: Mississippi.
Posts: 3,951
Yeah, I don't guess I have ever seen a Mercury switch on a vehicle light switch before. Seems like an odd choice to use.
__________________
To all who serve, Thank You.
amerijeep is offline   Quote Quick Reply
Old 09-22-2006, 10:38 PM   #8
Pushy, Loudmouthed, and Ballsy
 
Dare2BSquare's Avatar
 
Join Date: Jul 2006
Location: Driving Around Arkansas In My Black XJ
Posts: 6,177
Wait a minute. Bigjeep aren't you the one talking the other day about hosing down your engine compartment after going muddin'? Check your fuses.
__________________
99 XJ Sport
4.0l
AW4
NP231
d30/C8.25
3" Skyjacker lift
31 x 10.50 General Grabbers


http://i66.photobucket.com/albums/h2...are/TMLogo.gif Are all fishermen liars, or do only liars fish?
Dare2BSquare is offline   Quote Quick Reply
Old 09-22-2006, 10:38 PM   #9
Jeeper
 
mrbigjeep's Avatar
 
Join Date: Apr 2006
Posts: 4,288
yep...where exactly would that be...in the box on the left side under the hood?

mrbigjeep is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rebuilding your engine?? Get Stroked!!! jeeper95yj YJ General Discussion Forum 6 01-01-2014 04:47 PM
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
Part/time 4WD light not working? JASONSPAZ YJ Tech Forum 4 01-12-2011 12:23 PM
check engine light, tied to 4WD use? frankfletez YJ Tech Forum 2 08-09-2008 12:54 PM
Check Engine Light vin211 TJ Tech Forum 4 04-07-2008 09:12 AM



» Featured Product

All times are GMT -5. The time now is 10:56 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC