Engine miss help. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-21-2011, 03:39 PM   #1
Jeeper
 
Join Date: Dec 2010
Posts: 58
Engine miss help.

Hello,

I have recently determined that what I thought was a driveline issue (u-joint or driveshaft issue) might be an engine miss. My 2001 Jeep w/ the 4.0 vibrates when it is in high gear at about 40-50 mph and 1.4k rps going up a hill under light throttle. If i give it more gas or let of the gas, the vibration goes away.

It also vibrates the same way when I am accelerating and maintaining at interstate speeds. I just replaced the spark plugs and that did not help. Could the coil pack rail be causing this or maybe fuel injectors?

Maybe I should try some sea foam next.

Keep in mind there is no rough idle and the rest of the time it drives great.

p95loser is offline   Quote Quick Reply
Old 01-22-2011, 03:15 PM   #2
Jeeper
 
Join Date: Dec 2010
Posts: 58
Any ideas??? I seafoamed the intake and that did not help (didn't really expect it to). I also put some fuel injector cleaner in the gas tank and cleaned the K&N.

Is the coil rail or a fuel injector a more common cause of the issue I am describing?

p95loser is offline   Quote Quick Reply
Old 01-22-2011, 03:19 PM   #3
Jeeper
 
jasonwrangler's Avatar
 
Join Date: Oct 2010
Location: Omaha, NE
Posts: 892
1400rpm going up hill you kidding right?
you lugging the engine like that it will vibrate like crazy.
__________________
97 SE still running strong.
jasonwrangler is offline   Quote Quick Reply
Old 01-22-2011, 03:41 PM   #4
Jeeper
 
Join Date: Dec 2010
Posts: 58
It also does it on the interstate. When the engine is under load in 3rd gear.
p95loser is offline   Quote Quick Reply
Old 01-22-2011, 04:26 PM   #5
Jeeper
 
jasonwrangler's Avatar
 
Join Date: Oct 2010
Location: Omaha, NE
Posts: 892
Quote:
Originally Posted by p95loser View Post
It also does it on the interstate. When the engine is under load in 3rd gear.
the only way is to replace possible parts. unless there is a code specifically telling you what the problem is.
__________________
97 SE still running strong.
jasonwrangler is offline   Quote Quick Reply
Old 01-22-2011, 04:51 PM   #6
Jeeper
 
Join Date: Dec 2010
Posts: 58
After you mentioned that I was lugging the engine, I did some research and think this is possibly what is going on.

I had a YJ and it never did that, but I was also 18 years old and didn't know the meaning of a light throttle.

The jeep is not throwing any codes and whenever i give it a little more throttle, it goes away. I know it has 307 gears and I bet I am straining the engine.
p95loser is offline   Quote Quick Reply
Old 01-22-2011, 04:51 PM   #7
President, ThumbJeeps

WF Supporting Member
 
sevenservices's Avatar
 
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 3,938
you know... when you let off the gas it relevies pressure off the U-Joints. Go with your initial feeling.
__________________
-Chris
President, ThumbJeeps
CB Callsign "AirForce One"


1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 4" RC (33x12.5) (15x8) 3:54 Gears
sevenservices is offline   Quote Quick Reply
Old 01-28-2011, 08:04 PM   #8
Jeeper
 
Join Date: Dec 2010
Posts: 58
Just an update for anybody who cares... I found the issue. I was experiencing torque converter shudder. I bought a tube of Dr. Tranny's torque converter shudder fixx and put it in the fluid. Problem was fixed instantly, this stuff is awesome and only 7 bucks.

p95loser is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light tbowden91 YJ Tech Forum 28 03-07-2014 10:20 PM
4.0 I6 Sneaky Engine Tick (80,000 Miles) localfiend TJ Tech Forum 25 01-21-2011 03:10 AM
[B]Miss fire after i start engine![/B] Rebuilt YJ Tech Forum 1 12-06-2009 07:39 AM
05 blown engine tinworm TJ General Discussion Forum 10 10-27-2009 10:58 AM
New to forum, engine install time deaglementor YJ Tech Forum 7 05-07-2009 11:14 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:37 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC