Engine/Running Problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-13-2010, 08:57 PM   #1
Jeeper
 
Brad[LK1]'s Avatar
 
Join Date: Jan 2009
Location: Western PA
Posts: 424
Send a message via AIM to Brad[LK1]
Engine/Running Problems

I've been having a problem with my 1997 Wrangler 4.0L....After I drive it for awhile, the engine all of a sudden sputters out and has no power and eventually just stalls sometimes, other times if you pull over and put in park it recovers after a few minutes. Other times you have to shut it off and it lights right back up no problems after only being off a second or two.....I'm thinking something electrical. Any ideas?? Any and all help is welcome

Brad[LK1] is offline   Quote Quick Reply
Old 05-15-2010, 12:37 AM   #2
Jeeper
 
pokey's Avatar
 
Join Date: Feb 2010
Location: backroads of the Mojave
Posts: 1,106
It's possible your battery is on it's last leg. If the battery is almost dead the engine will run rough/stall like you describe. The alternator isn't enough to keep it running smoothly. I would have the battery checked. Good luck.

__________________
__________________________________________
. . . . picking the lines with my twenty-nines . . . .
__________________________________________

'99 sport 4.0 5 speed, top-of-the-line floormats
pokey is offline   Quote Quick Reply
Old 05-15-2010, 04:42 AM   #3
Jeeper
 
sjlawr's Avatar
 
Join Date: Jul 2009
Location: Oklahoma City, OK
Posts: 80
Along with the battery, it sounds very similar to a fuel pump issue. I have not seen this on a Wrangler yet, but on some of the other cars I have worked on in the past. As the fuel pump wears it over heats after running a while and cannot pump as much gas. Once you turn the car off, and let it recover, it runs fine again.
sjlawr is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My Clutch Problems and How I Resolved Them linz TJ Tech Forum 6 05-10-2013 07:11 PM
how to fix all vacume problems and how to locate the problems. Captaincoop1220 YJ Tech Forum 50 02-23-2013 12:19 PM
YJ Problems sooboss YJ Tech Forum 12 08-18-2010 01:17 PM
Fuel injector cleaner caused major problems. NEED HELP!! dwilliams59 YJ Tech Forum 2 03-14-2008 10:52 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:23 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC