Engine Sputters at 2500rpms - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-05-2009, 02:47 PM   #1
Member
 
Join Date: Feb 2007
Location: Boulder, CO
Posts: 106
Engine Sputters at 2500rpms

Ok, today the engine started sputtering when I hit 2500rpms. It is almost like I am hitting some sort of rev limiter. When I down shift at speed to get the RPMs above 2500 the gas pedal seems to have no affect until the rpms drop back down to 2500 and then the sputtering starts again. The engine acts completely normal below 2500. Also the check engine light is on. All other gauges are normal. All Fluids are normal.

The only thing I have an issue with right now is the Clutch Interrupt is just about shot and sometime I have to put it in 4 low to start it.

Any thoughts on what is causing the sputtering at 2500rpms.

Beowulf is offline   Quote Quick Reply
Old 06-05-2009, 03:59 PM   #2
Member
 
Join Date: Feb 2007
Location: Boulder, CO
Posts: 106
More info. I took a drive at lunch and the sputter at 2500rpms has stopped by my engine block light is still on.

From another forum the TPS was suggested as a possible point of issue.

Beowulf is offline   Quote Quick Reply
Old 06-05-2009, 04:53 PM   #3
Member
 
Join Date: Feb 2007
Location: Boulder, CO
Posts: 106
Error code is P-0344
Beowulf is offline   Quote Quick Reply
Old 07-31-2009, 06:05 PM   #4
Newb
 
Join Date: Jul 2009
Posts: 1
Hey there, I have the same problem. Did you ever figure out what it was?

Thanks!
alewine is offline   Quote Quick Reply
Old 09-14-2009, 12:23 PM   #5
Member
 
Join Date: Feb 2007
Location: Boulder, CO
Posts: 106
I never did find out what was the cause. It never happened after that incident. After taking it in to Jeep, they only stated that there was a TSB for it and did a flash. Oh well. As long as it does not happen again, I won't worry about it.
Beowulf is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rebuilding your engine?? Get Stroked!!! jeeper95yj YJ General Discussion Forum 6 01-01-2014 04:47 PM
Mounting engine mount brackets... 1992wranglersahara YJ Tech Forum 3 06-02-2009 07:40 PM
No spark!!! Asains YJ Tech Forum 3 05-26-2009 06:10 PM
New to forum, engine install time deaglementor YJ Tech Forum 7 05-07-2009 11:14 PM
Spedo dies and the engine dies when I brake jbhouse2k TJ Tech Forum 4 03-06-2007 07:17 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:06 PM.



Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC