Front End Question - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-24-2010, 09:53 AM   #1
Jeeper
 
Cdubu52's Avatar
 
Join Date: Jun 2010
Location: Pittsboro, NC
Posts: 89
Front End Question

I have a question. Is there supposed to be a little bit of give/play on the Drag Link and Tie Rod. I have been experiencing some front end shimmy and I was under the Jeep, just checking the fittings and all of the connections and when I put my wrench on the Steering stabilizer the drag link would roll a little. It would compress the grease fitting on the pittman arm and where the drag link meets the passenger side wheel assembly. I did notice a crack in the rubber boot where the pittman arm is connected to the drag link. I checked to make sure that all of the fittings were greased and there are no problems there. I noticed the same thing with the tie rod. It would also turn, not a loose bolt, but just enough to compress the grease boot. I just wanted to check and make sure that I didnt have a bigger problem.

Cdubu52 is offline   Quote Quick Reply
Old 08-24-2010, 10:09 AM   #2
Jeeper
 
wansfel's Avatar
 
Join Date: Mar 2010
Location: Stevesnville, MT
Posts: 104
Normal for the drag link and tie rod to rotate. Part of the design, but NOT okay for end to end play for either. If you detect any "clunking" when manhandling, then there is probably wear. If the rubber boots are cracked, its time to start planning to change the tie rod/drag link ends as they will collect dirt etc. and resulting wear. Not a complex job, but the right tools help (tie rod breaker).

__________________
95 YJ
2.5 4cyl/5 spd
RE 2.5" lift 31x10.5 -15 Wild Country XTX
wansfel is offline   Quote Quick Reply
Old 08-24-2010, 10:50 AM   #3
Jeeper
 
Cdubu52's Avatar
 
Join Date: Jun 2010
Location: Pittsboro, NC
Posts: 89
Whew. There is no side to side play, just rotational. Just wanted to make sure that I hadnt screwed something up. Everything else was pretty tight. Thanks.
Cdubu52 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Build Sheet Question Boosta JK General Discussion Forum 5 08-24-2010 11:35 AM
Front end Hitch under Front Bumper? STxWrangler JK General Discussion Forum 2 07-28-2010 11:51 AM
front end diff question wavebacktothetj TJ Tech Forum 2 07-18-2009 07:26 PM
Front Bumper Question? jrgfox TJ General Discussion Forum 2 04-06-2007 11:39 PM
front drive shaft question Theoldone TJ Tech Forum 9 04-03-2007 11:08 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:03 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC