Front engine mounts in pieces - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-03-2010, 02:50 PM   #1
Newb
 
Join Date: Jun 2010
Location: Cody WY and Borrego Spgs. CA
Posts: 12
Front engine mounts in pieces

My 2004 sport was purchased used. It came with 2" lift.
I have just discovered that the steel surrounds of both front engine mounts are broken or cut. It's a clean horizontal cut or break on each outboard side.
Could this be someones cure for some unknown problem or are these prone to this failure?

Wyoham is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
the engine hoist saga continues... tiny terror Off-Topic 14 08-28-2009 01:02 AM
Oil pan leaking in front of engine blacksport TJ Tech Forum 0 06-26-2009 08:21 PM
Mounting engine mount brackets... 1992wranglersahara YJ Tech Forum 3 06-02-2009 07:40 PM
Front end issues 4point TJ Tech Forum 11 06-02-2008 06:38 PM
Please 'splain the front axle to me. JoeyT YJ General Discussion Forum 6 04-20-2008 09:29 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:41 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC