Front Washer Pump dead? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-08-2011, 08:43 AM   #1
Jeeper
 
Join Date: Jul 2010
Posts: 109
Front Washer Pump dead?

Well it's inspection month and I just realized my front wiper spray doesn't work. The rear spray works fine, as do the wipers in front and back. When I press the button for the rear I hear a pretty loud motor noise. When I press for the front I can hear something but it's extremely faint.

In the picture below, I know the front motor is on the right. In what I thought was a moment of genius, I switched the tubes yet somehow that didn't do anything. I also tried removing the front tube and pressing the wiper wondering if it would shoot out (hoping for a clog) but nothing happened except it dripping out the now empty hole.

I've read all the posts on the topic and some said to test the motor by getting something from radio shack to measure something. Based on what it's doing, is it safe to say I just need a new pump? In that case, is it just replacing that pump with something like 1998-2006 Jeep Wrangler Washer Pump - Trico



As always, thanks for helping me out of a situation where I'm over my head...

ollie526 is offline   Quote Quick Reply
Old 01-08-2011, 08:48 AM   #2
Jeeper

WF Supporting Member
 
jeepjones's Avatar
 
Join Date: Jul 2010
Location: Canada, Eh?
Posts: 1,892
If you switched hoses and you still can't get fluid out to the windsheild I'm going to have to say they're is some wrong with or blocking the hoses.

__________________
jeepjones is offline   Quote Quick Reply
Old 01-08-2011, 10:06 AM   #3
Jeeper
 
Neil F.'s Avatar
 
Join Date: Nov 2007
Location: Marlton, NJ
Posts: 4,594
Images: 1
Disconnect the hose at the nozzle and see if it's the nozzle that is clogged.

You are kidding that the washer is checked for inspection?
__________________
2003 TJ, 33" BFG AT, 2" BL, 2" BDS spring lift, 55w DDM HIDs
Neil F. is offline   Quote Quick Reply
Old 01-08-2011, 10:32 AM   #4
Jeeper
 
Join Date: Jul 2010
Posts: 109
In Mass they test for washer fluid so if they wanted to they could fail for that.


The nozzle isn't clogged as it poured out when I pulled off the hoses when I swapped them. Does the front motor make the same sound as the back?


If I need a new pump does the kind matter? The one in the link was 30 but amazon has some that it says fits for half that.
ollie526 is offline   Quote Quick Reply
Old 01-08-2011, 11:35 AM   #5
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 29,225
Images: 2
Swap the two pumps, they are only held into the washer bottle with an o-ring.
__________________
When you have a choice, buy American.

Jerry Bransford is online now   Quote Quick Reply
Old 01-08-2011, 11:41 AM   #6
Jeeper
 
Join Date: Jul 2010
Posts: 109
I switched the hose and it didn't work. Would switching the side the pumps are on do anything? It'd be easy to try but it'd make a mess
ollie526 is offline   Quote Quick Reply
Old 01-08-2011, 11:45 AM   #7
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 29,225
Images: 2
So no matter what pump the front nozzle hose is connected to it won't squirt the windshield?
__________________
When you have a choice, buy American.

Jerry Bransford is online now   Quote Quick Reply
Old 01-08-2011, 12:07 PM   #8
Jeeper
 
Join Date: Jul 2010
Posts: 109
Solved! Thanks for all the quick ideas. I ended up trying to switch the hoses again and also played around with the wiring. Now I have it so the front works and the back is dead, but that's fine by me. I tested both wires and both work so it's just a matter of the pump. Does it matter which kind I get?

ollie526 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
4 low or high? dfwislander JK General Discussion Forum 186 05-28-2012 10:08 PM
The walking dead adkjoe Off-Topic 66 12-08-2010 08:48 AM
Winch on front bumper or on receiver hitch for front and back? mike1655 TJ General Discussion Forum 6 10-26-2010 07:07 PM
1997 - 2006 Jeep Wrangler FRONT Track Bar (MOOG DS1235) 1ATony Vendor Spotlight! Great Deals for Members. 0 10-20-2010 10:01 AM
Its dead, its not dead...its dead, its not dead!!! chrisb0108 TJ Tech Forum 10 09-15-2010 12:16 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:49 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC