Fuel pump probs - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-04-2013, 05:06 PM   #1
Jeeper
 
Join Date: Nov 2012
Location: Siloam Springs, AR
Posts: 60
Fuel pump probs

So I left my headlights on this morning, and when I came out from work this afternoon, my battery was dead. No problem. I had a friend try to jump start me, but no start. It's either fuel or fire. All the fuses look good. Please help.

__________________
My build thread
dlm32067 is offline   Quote Quick Reply
Old 11-04-2013, 05:12 PM   #2
Jeeper
 
j33p3rz cr33p3rz's Avatar
 
Join Date: May 2010
Location: Franklin,Indiana
Posts: 176
Sounds like u need a new battery.This happened to me a few years ago.We tried to jump it charge it and was a no go.Swapped battery and was good to go.

__________________
/l ,[____],
l---L -OlllllllO-
()_)-()_)-o-)_)
j33p3rz cr33p3rz is offline   Quote Quick Reply
Old 11-05-2013, 05:36 PM   #3
Jeeper
 
Join Date: Nov 2012
Location: Siloam Springs, AR
Posts: 60
I took the battery to O'Reilly's on my lunch break with full intentions of buying a new one, but they talked me into testing the battery first. It was so low they couldn't even test it without charging it first! I picked it up after work with a "good" sticker on it, installed it, and drove home. Amazing!
__________________
My build thread
dlm32067 is offline   Quote Quick Reply
Old 11-06-2013, 10:58 AM   #4
Jeeper
 
Join Date: Sep 2013
Posts: 49
These newer buggies are way different than the cars of the 60's and 70"s with points and condensers that controlled the ignition coils, one really needs some battery voltage available for them to run now days. Glad you got your trouble solved and your lucky the battery came back. since most went to maintenance free batteries once they run flat you mostly can't get them to come back to life recharging them, at least that's my experience.
gfiber is offline   Quote Quick Reply
Old 11-06-2013, 11:11 AM   #5
Jeeper
 
j33p3rz cr33p3rz's Avatar
 
Join Date: May 2010
Location: Franklin,Indiana
Posts: 176
Glad it worked out.
__________________
/l ,[____],
l---L -OlllllllO-
()_)-()_)-o-)_)
j33p3rz cr33p3rz is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 07:24 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC