Fuse question.....please help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-05-2007, 11:04 AM   #1
Newb
 
Join Date: Dec 2007
Posts: 1
Fuse question.....please help

my cig lighter doesn't work whenever i plug anything into it (and i need it for my sirius). Everything else is functional on my dash so i am not sure if this is a fuse problem or what. THe fuses on my jeep are difficult to read so i was wondering if anyone knew how to fix this?

97wrangler is offline   Quote Quick Reply
Old 12-05-2007, 11:52 AM   #2
Jeeper
 
tazmann910's Avatar
 
Join Date: Apr 2007
Location: Atlanta Georgia
Posts: 2,143
Send a message via AIM to tazmann910 Send a message via Yahoo to tazmann910
Pull your dash apart and see if the lighter is still connected.

__________________
03 TJ with a bunch of upgrades...
Off The Map 4 Wheel Drive Club.
tazmann910 is offline   Quote Quick Reply
Old 12-05-2007, 01:48 PM   #3
Jeeper
 
parrot head's Avatar
 
Join Date: Jul 2007
Location: Connecticut
Posts: 406
Was the lighter ever used to light cigarettes? Check inside the plug and see if there is any old ash stuck in there, or if there is any corrosion inside that is preventing you from making a good connection.
__________________
“He who knows not and knows not that he knows not, he is a fool, shun him.
He who knows not and knows he knows not, he is simple, teach him.
He who knows and knows not he knows, he is asleep, wake him.
But he who knows, and knows he knows, he is wise, follow him.”


89 yj 4 banger 5sp. 2" BL 31x10.50 fixed up and sold
97 tj 4.0 Auto 4"RC lift 33x12.50 mud rovers on outlaw IIs . Smitty bumpers
parrot head is offline   Quote Quick Reply
Old 12-05-2007, 10:10 PM   #4
Jeeper
 
Join Date: Sep 2006
Location: Redmond, WA
Posts: 37
Also, you might look at the connection at the end to make sure it isn't pressed down too far. I thought mine was bad too until I got a new GPS with a 12volt connector that was long and skinny, now my 12 volt works if the connector is pressed in all the way. I think I can remedy the problem by disconnecting the power and bending it forward a bit.

Bob
kc7yrs is offline   Quote Quick Reply
Old 12-06-2007, 01:00 AM   #5
Jeeper
 
Rawkon's Avatar
 
Join Date: Apr 2005
Location: fullerton/big bear
Posts: 2,061
Send a message via AIM to Rawkon Send a message via MSN to Rawkon
check the fuse before pulling the dash.

its fuse 19 and its a 20amp. it should be located behind your glove box.
Rawkon is offline   Quote Quick Reply
Old 12-06-2007, 01:17 AM   #6
Nerf gun assassin

WF Supporting Member
::WF Administrator::
 
distortedtj's Avatar
 
Join Date: May 2005
Location: yep right there.
Posts: 21,258
Send a message via Yahoo to distortedtj
Quote:
Originally Posted by Rawkon View Post
check the fuse before pulling the dash.

its fuse 19 and its a 20amp. it should be located behind your glove box.
x2
distortedtj is offline   Quote Quick Reply
Old 12-06-2007, 02:27 AM   #7
Jeeper
 
Join Date: Sep 2006
Location: pahrump Nevada
Posts: 1,241
Quote:
Originally Posted by Rawkon View Post
check the fuse before pulling the dash.

its fuse 19 and its a 20amp. it should be located behind your glove box.
X3
mr4x4 is offline   Quote Quick Reply
Old 12-06-2007, 11:08 PM   #8
Jeeper
 
98TJ's Avatar
 
Join Date: Oct 2007
Location: Vestal
Posts: 127
had the same problem occur. check your fuses. i cant remember which one it is but jeep put too small of a fuse in the box for the lighter. i replaced it with like a 30amp i think
98TJ is offline   Quote Quick Reply
Old 12-09-2007, 10:15 PM   #9
Newb
 
Join Date: Aug 2007
Posts: 7
i had the same problem .Check the fuse under ther hood.
E-33 is offline   Quote Quick Reply
Old 12-09-2007, 10:58 PM   #10
Jeeper
 
rketr's Avatar
 
Join Date: Sep 2007
Location: San Antonio, TX
Posts: 866
Recently had the same prob. Replaced a 20 amp fuse under the hood in the spot marked "power." Once replaced, everything worked fine again...

rketr is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Auxillary Lighting Install Writeup erickpl General Jeep FAQ/Stickies 15 09-20-2013 09:28 AM
Auxilary Lighting Writeup erickpl TJ Tech Forum 2 01-06-2011 07:50 PM
PDC Relay or fuse.. Keeps on Popping Need Help! BravoSSER TJ Tech Forum 1 12-04-2008 09:39 PM
fuse box question Buc Knaked YJ Tech Forum 2 09-15-2008 10:51 PM
98 TJ fuse question hmmm70 TJ Tech Forum 7 04-04-2008 10:20 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:57 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC