gauges, radio & interior lights don't work - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-17-2011, 10:19 AM   #1
Newb
 
Join Date: Jun 2011
Posts: 7
gauges, radio & interior lights don't work

Help please! It is not the fuses, the grounds are all ok... so what else could it be? I started her up last week and these didn't work... drove her for a bit and hit a nice bump and they all came back on... then the next morning they didn't work again and haven't since. Taken everything apart and cannot seem to find what's up. Could there be a fuse inside the gauge box? All the lights on the gauge box work - fuel light, brake light, check engine, check gauges, air bag, shift indicator, when the engine is started but no gauges - no radio and no interior lights and it is driving me crazy!!!

Any insight would be greatly appreciated!!!
peacejeep 97 TJ

peace jeep is offline   Quote Quick Reply
Old 08-17-2011, 10:22 AM   #2
Knows a couple things...

WF Supporting Member
 
Jerry Bransford's Avatar
 
Join Date: Nov 2005
Location: Escondido, Calif.
Posts: 32,293
Images: 2
Did you check the fuses in both locations they are found in? There are a bunch of fuses located inside the Power Distribution Center box located directly in front of the battery, inside the engine compartment.

__________________
Remember that having a different opinion doesn't also require one to be a jerk when expressing it.

When you have a choice, buy American.

Jerry Bransford is offline   Quote Quick Reply
Old 08-17-2011, 11:14 AM   #3
Newb
 
Join Date: Jun 2011
Posts: 7
Yes I did... at least I checked all the smaller fuses... what about all the large fuses? Kinda leary of the large ones - don't want to mess with any air bag stuff.
peace jeep is offline   Quote Quick Reply
Old 08-17-2011, 09:42 PM   #4
Jeeper
 
Shelby427's Avatar
 
Join Date: May 2011
Location: Lakeland FL and Hooversville PA
Posts: 2,130
Looking at the service manual, fuses # 3 and 17 in the under hood power distribution center are the ones that run the gauges, radio, and interior lamps.

But the bump in the road causing them to work, then stop, sounds more like a poor connection somewhere rather then a fuse.
__________________
97 Sahara, 74 Renegade, 72 CJ5, 55 Willy's (the Beast) Boss 302, 6:34 gearing, Bose 901 speakers.
God I miss that Jeep. Forgot the kinda Jeep, 80 SX4.
Shelby427 is offline   Quote Quick Reply
Old 09-26-2013, 06:26 PM   #5
Newb
 
Join Date: Sep 2013
Posts: 1
sorry to resurrect this thread but you may consider checking the airbag control module and the wiring harness in the steering column that goes to the airbag in the steering wheel. i had the same exact issue and seems this is a common problem. you will probably have a 15 amp fuse popped in the fuse box / power distribution block in then engine compartment too.

i do apologize for posting in an old thread but i wanted to make sure that if anyone is having this issue they atleast have a starting point.
plecostemus is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Aftermarket radio and speakers wont work BryceR YJ Tech Forum 9 12-22-2012 12:25 AM
cruise controll doesnt work/ xm radio guerriero321 TJ General Discussion Forum 8 03-31-2011 01:35 PM
Radio, Gauges, and Dome lights don't work. LoneJeeper TJ Tech Forum 9 07-12-2009 06:54 PM
twin computer set up and gauges still don't work? jroth TJ Tech Forum 1 07-02-2006 09:16 PM
my weekend work on the jeep (rambling) whitebuffalo General Jeep Discussion 6 07-18-2005 11:05 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:53 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC