Grinding question - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 11-12-2012, 10:47 AM   #1
KevinNJ's Avatar
Join Date: Jul 2012
Location: Morris County NJ
Posts: 341
Grinding question

My 2002 4.0 5 speed has been having issues ever since I got it, living up the J.E.E.P acronym. Engine went at 148k so I just had it replaced with a Jasper. Shop checked out the clutch and that was ok. Pilot bearing had to be replaced and flywheel was shot and replaced.
Got everything back this past weekend. Now whenever I shift into 2nd from first or downshift into second there is an awfully bad grinding. I am going to change out the trans fluid to Red Line MTL. But just thinking if changing the fluid doesn't help, is there any chance when they put everything back together that something is lined up right or does the clutch need to be bled or something else I need to think of? I had some grinding on downshifting prior to the engine replacement, but now it it is happening everytime I shift (unless I shift deliberately slow). Thanks.

KevinNJ is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 12:19 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC