Headlights not working - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-06-2013, 09:10 PM   #1
Newb
 
Join Date: Oct 2013
Posts: 4
Headlights not working

Hey guys, so I bought my 1997 Jeep Wrangler Sport about 2 weeks ago up in Michigan. I bought it as is knowing that I would have to do some work to it. Since then my main issue is that the headlights are not working. When I pull the light nob nothing happens. If I turn on the switch for the fog lights they work fine but the regular beams/ high beams never come on.

I've gotten a few opinions about what could be causing this problem. I've heard it could be a relay somewhere or that it could be the ground. Has anyone else had this issue and if so what should I do to try to fix it?

jwroyer is offline   Quote
Old 10-06-2013, 09:44 PM   #2
Jeeper
 
R u s s's Avatar
 
Join Date: Jul 2013
Location: Snohomish County
Posts: 358
Head light switch is where I would start unless the wiring has been hacked.

R u s s is offline   Quote
Old 10-07-2013, 08:07 PM   #3
Newb
 
Join Date: Oct 2013
Posts: 4
But if I pull the headlight switch to the "On" position it turns the fog lights on. Could it just be the connection to the headlights that is broken in the switch?
\
jwroyer is offline   Quote
Old 10-07-2013, 08:47 PM   #4
Supporting Member

5-Year WF Supporting Member
 
Water Dog's Avatar
 
Join Date: Mar 2011
Location: Roseville, CA
Posts: 8,067
My guess is the multifunction (dimmer switch), On the steering column, with the headlights on, see if you have power on the light green wire (input). If so, see if you have power on the violet/white wire (low beam output) or red/orange wire (high beam output). If not, replace the multifunction switch.

Oh, also check fuse #10 (30 amp) in the power distribution center under the hood.

BTW..power to the fog light relay is fed by the black/yellow wire from the headlamp switch. These colors are from a 1999 FSM, but should be the same as yours.
__________________
Dennis
Water Dog is offline   Quote
Old 10-08-2013, 05:05 PM   #5
Newb
 
Join Date: Oct 2013
Posts: 4
Thanks I'll check it out!
jwroyer is offline   Quote
Old 06-26-2015, 07:59 PM   #6
Newb
 
Join Date: Jun 2015
Posts: 1
Hi guys, I know this is an old thread, but I am now having a similar problem. Were you able to fix this? The problem I am having with my 1997 Wrangler is that the hi-beams and the park/low-beams work fine, but the regular headlights are not working. When I pull the switch out to turn on the headlights, all I get is the park lights, though turning on the high-beams works fine. Anyone know what could be causing this and how to fix it?

Brodiefett is offline   Quote
Reply

Tags
headlights , help advice , newb problems

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:13 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC