heater doesn't work - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-30-2009, 03:24 AM   #1
Jeeper
 
Wald0's Avatar
 
Join Date: Sep 2009
Posts: 28
heater doesn't work

normally it hardly blows any air at all, sometimes it blows a little bit, and sometimes it blows at the setting you have it....and this is all when its on the highest setting. any idea what this could be or a way to fix it? its starting to get cold, and my hour drive to work each day is sucking. Ive noticed when I hit a bump it will often blow harder for a few minutes for some reason.

__________________
2000 TJ Wrangler, 2 in lift on 32s
2006 SRT8 Charger, Airaid Intake
^^^SRT IS FOR SALE!!!^^^
Wald0 is offline   Quote
Old 09-30-2009, 05:48 AM   #2
Jeeper
 
snwchris's Avatar
 
Join Date: Jan 2009
Location: NE Ohio
Posts: 1,718
First I would check the vacuum line on the engine block, driverside rear corner. You should see a small vacuum line that should be connected to a barb on the engine block. I had to zip tire mine on since would keep sliping off.

2nd, If not that next the lines behind control panel and fuses in the glove box.

3rd would probably be blower resistor.

Chris

__________________
98TJ / Hi-Lined / Zip Lockers / 35s


Family Rig / Tow Rig: 08 Tundra & 16ft Trailer
snwchris is offline   Quote
Old 09-30-2009, 07:20 AM   #3
Jeeper
 
Wald0's Avatar
 
Join Date: Sep 2009
Posts: 28
ic thanks! Ill check those out if it warms up....35 degrees out right now...wtf?
__________________
2000 TJ Wrangler, 2 in lift on 32s
2006 SRT8 Charger, Airaid Intake
^^^SRT IS FOR SALE!!!^^^
Wald0 is offline   Quote
Old 09-30-2009, 07:41 AM   #4
Jeeper
 
Join Date: Jan 2009
Posts: 132
(There He Is!!--sorry man, I could not resist) If it switches from defrost to dash to feet then it is not a vaccuum problem. it sounds like a blower resistor or switch issue. My money is on the resistor. good luck!
Mrmikeypoo is offline   Quote
Old 09-30-2009, 10:49 AM   #5
Jeeper
 
snwchris's Avatar
 
Join Date: Jan 2009
Location: NE Ohio
Posts: 1,718
Mine would only blow out the feet on the highest setting, when I looked at the vacuum line and saw it was disconnected from the barb, I hooked it back up and then it worked on all settings and even on low for the blower.

Chris
__________________
98TJ / Hi-Lined / Zip Lockers / 35s


Family Rig / Tow Rig: 08 Tundra & 16ft Trailer
snwchris is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater question wafarmtrk YJ Tech Forum 1 08-18-2009 11:52 PM
Heater Problems? Giancarlo TJ Tech Forum 4 12-06-2007 05:23 PM
Estimate on mechanical work diab-o TJ General Discussion Forum 2 10-30-2007 09:40 PM
heater oneman275 YJ Tech Forum 5 02-08-2006 10:14 PM
my weekend work on the jeep (rambling) whitebuffalo General Jeep Discussion 6 07-18-2005 11:05 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:57 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC