Heater help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-28-2010, 07:10 PM   #1
Newb
 
Join Date: Nov 2010
Posts: 13
Heater help

Hi all I was woondering if I could get somefeed back from you guys pretaining to my heater. Well the heater does not blow hot, I checked the heater core hoses and when up to temp I notice they are both very hot, do I am assuming the heater core is not blocked, While checking this I noticed my AC compressor clutch was engaged, so I went into the cabin and the climate controll dial that goes from blue for cold to red for hot, does not seem to be changing, There is no resistance and I do not notice any change from blue to red. Any ideas on what this could be would be greatly appreciated. Thanks again, John

Parrish_Jeep is offline   Quote Quick Reply
Old 11-28-2010, 07:13 PM   #2
Nerf gun assassin

WF Supporting Member
::WF Administrator::
 
distortedtj's Avatar
 
Join Date: May 2005
Location: yep right there.
Posts: 21,258
Send a message via Yahoo to distortedtj
pull the switch off and see if it has cracked....just grab it and pull straight out.

distortedtj is offline   Quote Quick Reply
Old 11-28-2010, 07:21 PM   #3
OIIIIIO

WF Supporting Member
 
T2000J's Avatar
 
Join Date: Sep 2010
Location: PA
Posts: 887
If you have it set on defrost the ac compresser will kick on and off ....
whats the temp reading ?
__________________


JEEP WRANGLER
T2000J is offline   Quote Quick Reply
Old 11-28-2010, 07:21 PM   #4
Newb
 
Join Date: Nov 2010
Posts: 13
I pulled on it and it doesnt come off
Parrish_Jeep is offline   Quote Quick Reply
Old 11-28-2010, 07:25 PM   #5
Newb
 
Join Date: Nov 2010
Posts: 13
Could have been on defrost, However I still dot think it is the heater core, The temp of te jeep was right on 200 degrees, What does the climate control knob attach to?
Parrish_Jeep is offline   Quote Quick Reply
Old 11-28-2010, 07:37 PM   #6
Jeeper
 
Stick69's Avatar
 
Join Date: Sep 2010
Posts: 24
More than likely it's just a cracked temp knob. I just went through this on mine. A little glue and a vice to clamp it back together and all is back to normal. Just grab the knob and pull straight out.
Stick69 is offline   Quote Quick Reply
Old 11-28-2010, 07:50 PM   #7
Jeeper
 
jasonwrangler's Avatar
 
Join Date: Oct 2010
Location: Omaha, NE
Posts: 892
could be a broken blender door.
jasonwrangler is offline   Quote Quick Reply
Old 11-28-2010, 08:31 PM   #8
Newb
 
Join Date: Nov 2010
Posts: 13
Where is the Blender door located
Parrish_Jeep is offline   Quote Quick Reply
Old 11-28-2010, 09:38 PM   #9
Jeeper
 
neverfastenough1's Avatar
 
Join Date: Nov 2010
Location: Savannah, Ga
Posts: 925
If both hoses are hot then its not the core. +1 on the a/c compressor kicking in when on defrost. That is what removes the moisture from the air. If the knob doesn't have any resistance, which there won't be much anyways, then it could possibly be the knob is cracked like said, and like said just pull straight out on it and it will come off. The blend door is inside the airbox. It opens and closes when you adjust the temp. Is that the only thing that doesn't work? Can you change from vent to defrost and floor?
neverfastenough1 is offline   Quote Quick Reply
Old 11-28-2010, 10:38 PM   #10
Jeeper
 
Billytehbob's Avatar
 
Join Date: Aug 2010
Location: Irmo, SC
Posts: 84
How long does it take for the return hose coming from the heater core to heat up? Mine took a good while to heat up and would sporadically blow warm air. I flushed the heater core by running water from a garden hose through the return line which came through the input and into a bucket. I then flushed it the other way and did this back and forth a few times. Now I get pretty good heat and it blows hot air constantly
__________________
'99 Four-banger
Wants meaner tires
Billytehbob is offline   Quote Quick Reply
Old 11-29-2010, 06:35 AM   #11
Newb
 
Join Date: Nov 2010
Posts: 13
Hi all thanks for the help, The air ducts shift fine between defrost, floor, Just cool air not hot, The heater core hoses are heating up together they reach around 180 on my temp gun so I am happy knowing it is not them, I will try the knob
Parrish_Jeep is offline   Quote Quick Reply
Old 05-13-2014, 08:53 AM   #12
Newb
 
Join Date: May 2014
Location: Colorado
Posts: 4
I'm having the same issue, but also mine isn't switching from floor to dash to defrost
Falcor77 is offline   Quote Quick Reply
Old 05-13-2014, 08:54 AM   #13
Newb
 
Join Date: May 2014
Location: Colorado
Posts: 4
Also, mine was swapped from 4 cyl to 6 cyl, the check engine airbag and some other lights are always on…. that's not as big of an issue for me, but would be nice to get that all worked out as well… any ideas??

Falcor77 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Auxiliary Heater 4xplore Communications and Electronics 0 11-16-2010 10:29 PM
AC / heater problem Storm TJ Tech Forum 0 08-25-2010 09:57 AM
Fixing the heater core... TerrorJ2001 TJ Tech Forum 11 07-26-2010 04:12 PM
Heater question wafarmtrk YJ Tech Forum 1 08-18-2009 11:52 PM
heater problem hank1 TJ Tech Forum 2 11-13-2008 05:35 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:23 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC