Help... 1999 TJ randomly shuts down - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-06-2007, 08:57 AM   #1
Newb
 
Join Date: Jul 2007
Posts: 8
Question Help... 1999 TJ randomly shuts down

I'm a relatively new jeep owner. I have a 1999 TJ - L6 4.0 . I'm having a problem with my jeep randomly shuting down. I will be driving and all of the engine shuts down. Sometimes I can restart it in neut while I'm still rolling. Other times it takes 1/2 to an hour of sitting before it restarts. I've already replaced the coil, cap, rotor, sparks wires, plugs.. Still getting the problem. No one seems to know exactly why it's doing it.


Very frustrated :chair:

tyrch is offline   Quote Quick Reply
Old 07-06-2007, 08:59 AM   #2
Jeeper
 
debruins's Avatar
 
Join Date: Feb 2007
Location: Needham Ma, Rangeley ME in the summer
Posts: 5,578
Send a message via AIM to debruins
does it just shut down, or sputter and then die? anything else that may be able to help us out?

debruins is offline   Quote Quick Reply
Old 07-06-2007, 09:05 AM   #3
Newb
 
Join Date: Jul 2007
Posts: 8
Quote:
Originally Posted by debruins View Post
does it just shut down, or sputter and then die? anything else that may be able to help us out?

Just shuts down. RPM goes to 0 but the radio is still playing..
tyrch is offline   Quote Quick Reply
Old 07-06-2007, 09:30 AM   #4
coilovers are damn flexy
 
bluvikng's Avatar
 
Join Date: Mar 2006
Location: Texas
Posts: 3,260
Could be a sensor, gone bad. It could be a clogged fuel filter. It is hard to say, without doing some basic, step by step, diagnostics.
__________________
bluvikng is offline   Quote Quick Reply
Old 07-06-2007, 09:31 AM   #5
Jeeper
 
4.0l sahara's Avatar
 
Join Date: Apr 2007
Location: shelton,ct
Posts: 2,228
Well if the ignition is just cuting out I would think it would be a bad connection some where.Does the check engine light come on?
__________________
99 sahara
4.0/np231/ax15/d30/d35
flowmaster40,hpd30 with aussie locker,currie upper joints,4.88's, lca skids,chromo shafts,vanco brakes,d35 with super 35 and arb locker,re 4.5" springs,currie arms,re front uppers,Re shocks in back,walkerevens shocks up front, Re track bars with currie jj joints,anti rock,ss brake lines,re rear sway bar links,jks 1.25" bl and mml,bfg 35x12.5 km2's,craiger soft 8's,ome steering stabilizer,currie hd steering,rockmen front bumper,emp tank skid,lots more too.
4.0l sahara is offline   Quote Quick Reply
Old 07-06-2007, 09:42 AM   #6
Newb
 
Join Date: Jul 2007
Posts: 8
Quote:
Originally Posted by bluvikng View Post
Could be a sensor, gone bad. It could be a clogged fuel filter. It is hard to say, without doing some basic, step by step, diagnostics.

Thought about bad fuel filter/reg. However there is fuel under pressure in the fuel rail. (depressed the schrader valve and fuel jetted out). Swapped around relays btwn horn and fuel no diff... When it's "out" the ign coil is not outputing anything. Swapped the ecc relay when it was out and no difference.
tyrch is offline   Quote Quick Reply
Old 07-06-2007, 09:45 AM   #7
Newb
 
Join Date: Jul 2007
Posts: 8
Quote:
Originally Posted by 4.0l sahara View Post
Well if the ignition is just cuting out I would think it would be a bad connection some where.Does the check engine light come on?
Couldn't find one... Had about an hour last time before it restarted, checked over all my connections couldn't find one. I don't believe I seen a check engine light on.
tyrch is offline   Quote Quick Reply
Old 07-06-2007, 09:49 AM   #8
coilovers are damn flexy
 
bluvikng's Avatar
 
Join Date: Mar 2006
Location: Texas
Posts: 3,260
Do you have a dealership, in your area? I would ask their service department, what they think. Some of them will actually talk to you on the phone, without the "You have to bring it in here, for us to diagnose it". Just a thought. I know there are idle sensors, and few other sensors, that could contribute to this problem.
__________________
bluvikng is offline   Quote Quick Reply
Old 07-06-2007, 11:15 AM   #9
Jeeper
 
JCS05Rubi's Avatar
 
Join Date: Mar 2007
Location: central md
Posts: 2,748
Obviously this is just a shot in the dark, since I cannot be there to diagnos the Jeep, so please don't run out buying parts.

When I was in school, during Drivability Diagnosis class, our teacher told us about this same sort of scenario. He said it happens to EVERY tech sometime in there life, and it will take days to figure it out.

Driving down the highway, been driving about 30 minutes, its a nice hot day outside and BAM all the sudden the motor shuts off, and all tests are good. Once the car sits for awhile, and cools down, and starts right up and drives no problem. No codes found stored in the computer. The car will do this intermittantly, or happen frequently. Warm up, cut off, cool down and start right up. Usually surfaces during hot summer months (July-Sept) not during winter.

He said the problem is 90% of the time going to be the PCM. Yes, the main computer. He said what happens is (and it makes sence with a computer background) the computer is fine when cold, but being old and whatnot, the computer is worn down. When it gets hot, a solder point losses connection, or a resistor goes bad or something like that, I forget exactly what it was, but it goes out with heat, then shrinks back to normal and makes a solid connection when cold. He said its actually pretty common.


Now with that said, I worked on cars for 4 years, and then did Restoration work for over a year, and only had to replace a computer once. Don't go out buying a new one, but if you have a buddy that wouldnt mind switching PCMs with you for 2 hours or so to see if it fixes the problem, it wouldnt hurt.
__________________
Dad's Blog! http://justkeepliving.blog.com/
T-Shirts for Dad, based on his "Just Keep Living" philosophy. http://www.cafepress.com/justkeepliving


1997 Wrangler Sport - 5 spd. Retired
2005 Wrangler Rubicon - 6spd|KC 55watt fogs, IPF H4s with fatboys,Uniden CB radio/Teraflex mount
http://www.4x4s-pod.com/
JCS05Rubi is offline   Quote Quick Reply
Old 07-06-2007, 12:32 PM   #10
Newb
 
Join Date: Jul 2007
Posts: 8
Sounds exactly like what happens. Just took it up to autozone to run on the computer diag. No codes found. haven't had the trouble that long, so I couldn't tell you if it happens in winter or not... but thanks... had another suggestion that it was that.
tyrch is offline   Quote Quick Reply
Old 07-06-2007, 01:11 PM   #11
Jeeper
 
JCS05Rubi's Avatar
 
Join Date: Mar 2007
Location: central md
Posts: 2,748
like I said, its just a shot in the dark, and I wouldnt spend hundreds/thousands on a new computer just because I said so, BUT what my teacher described to me a few years ago seems very similar. Just something to chek since you have fuel/air and spark is basically all good unless you got a bad part or your PCM is going out.

Find a buddy with a Jeep similiar to yours, IE Same motor and trans, close to the same year, and swap computers. Just for 2 or 3 hours. Drive it around town and on the highway, getting it warm, doing what you do when it clunks out, and see if it fails. If you dont got a budd with a Jeep, look up a Jeep club in your area.
__________________
Dad's Blog! http://justkeepliving.blog.com/
T-Shirts for Dad, based on his "Just Keep Living" philosophy. http://www.cafepress.com/justkeepliving


1997 Wrangler Sport - 5 spd. Retired
2005 Wrangler Rubicon - 6spd|KC 55watt fogs, IPF H4s with fatboys,Uniden CB radio/Teraflex mount
http://www.4x4s-pod.com/
JCS05Rubi is offline   Quote Quick Reply
Old 07-07-2007, 03:18 PM   #12
Newb
 
Join Date: Jul 2007
Posts: 8
New thing I noticed... actually by accident. I left my A/c on as I turned off the jeep ( was running atm) and the blower still stayed on even after I had the key out of the ignition. Normally I shut down the a/c before removing the key so I didn't notice it. Also it was sugested that it may be vapor lock in the fuel line? Is that possible with 1/2 tank?
tyrch is offline   Quote Quick Reply
Old 07-07-2007, 03:24 PM   #13
coilovers are damn flexy
 
bluvikng's Avatar
 
Join Date: Mar 2006
Location: Texas
Posts: 3,260
Never heard of vapor lock with fuel injection.
__________________
bluvikng is offline   Quote Quick Reply
Old 07-07-2007, 03:39 PM   #14
Newb
 
Join Date: Jul 2007
Posts: 8
Quote:
Originally Posted by bluvikng View Post
Never heard of vapor lock with fuel injection.
Neither had I, but with all the strange things and this beening my 1st jeep couldn't rule it out before getting more options.
tyrch is offline   Quote Quick Reply
Old 09-22-2010, 07:38 AM   #15
Newb
 
Join Date: Sep 2010
Posts: 12
Bad crank sensor ?
4WD School is offline   Quote Quick Reply
Old 09-22-2010, 09:08 AM   #16
Jeeper
 
Fofo's Avatar
 
Join Date: Sep 2010
Location: portland or
Posts: 40
Quote:
Originally Posted by JCS05Rubi
Obviously this is just a shot in the dark, since I cannot be there to diagnos the Jeep, so please don't run out buying parts.

When I was in school, during Drivability Diagnosis class, our teacher told us about this same sort of scenario. He said it happens to EVERY tech sometime in there life, and it will take days to figure it out.

Driving down the highway, been driving about 30 minutes, its a nice hot day outside and BAM all the sudden the motor shuts off, and all tests are good. Once the car sits for awhile, and cools down, and starts right up and drives no problem. No codes found stored in the computer. The car will do this intermittantly, or happen frequently. Warm up, cut off, cool down and start right up. Usually surfaces during hot summer months (July-Sept) not during winter.

He said the problem is 90% of the time going to be the PCM. Yes, the main computer. He said what happens is (and it makes sence with a computer background) the computer is fine when cold, but being old and whatnot, the computer is worn down. When it gets hot, a solder point losses connection, or a resistor goes bad or something like that, I forget exactly what it was, but it goes out with heat, then shrinks back to normal and makes a solid connection when cold. He said its actually pretty common.

Now with that said, I worked on cars for 4 years, and then did Restoration work for over a year, and only had to replace a computer once. Don't go out buying a new one, but if you have a buddy that wouldnt mind switching PCMs with you for 2 hours or so to see if it fixes the problem, it wouldnt hurt.
As a mechanic/engineer I agree. If you have ever heard of the red ring of death on an xbox it's basiclly the same thing it gets to hot and the soders break because the silicon electronics board will warp. Often if a PCM is bad it for a reason so I would check for shorts or anything that could heat up the PCM like hot air. Bring the most expensive electrical part on your jeep I would take this guys advice on finding a friend just make sure its the same PCM otherwise you could damage your buddies.

__________________
~Fofo
Fofo is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 Wrangler Transmission Question. cyberunlimited TJ Tech Forum 10 09-03-2008 02:31 PM
1999 Sahara tiger22 Classifieds Archive 1 06-26-2007 09:53 PM
1999 Jeep TJ for sale (GA). 134K 4cly 5sp $6,500.00 cecoen Classifieds Archive 4 06-09-2007 11:48 AM
JEEP Wrangler 1999 Sport 4x4 4.0L 4 Sale sadeacs Classifieds Archive 1 05-02-2007 09:37 PM
1999 Wrangler For sale *low miles* joeamato88 Classifieds Archive 3 10-16-2005 12:51 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:24 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC