Help - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 01-19-2013, 07:49 PM   #1
jjone54's Avatar
Join Date: Oct 2012
Posts: 26

I replaced my radiator and i dont know if it has air in it or what but i cant figure it out, it warms up and keep getting to warm and heater doesnt blow heat, what am
I missing???? Is there a special way to bleed system and fill? Ive tried cap off trick. And still doesnt work

ad sq

jjone54 is offline   Quote
Old 01-19-2013, 08:44 PM   #2
DevilDogDoc's Avatar
Join Date: Jun 2010
Location: Yucca Valley CA 20 miles from JV
Posts: 2,362
I drive mine up on ramps at the front and idle it with the cap off for a while, I have never had air trapped in it and I have done it this way many times.

Violence may not be the answer but it sure cuts down on the stupid questions
DevilDogDoc is offline   Quote
Old 01-19-2013, 09:33 PM   #3
jameslee97206's Avatar
Join Date: Nov 2010
Location: Portland Oregon
Posts: 1,176
With the jeep running and the radiator cap off squeeze the upper and lower radiator hoses as well as the heater core hoses. Continue to add coolant as the the level drops and air bubbles come out. When there's no more bubbles you're done.
Warn M8000, KD Fabworks custom cage, Homemade sliders, 4:88, D44 ARB rear, Metalcloak arms and front track bar, Currie Currectlync, BFG KM2 35's ect....ect.
jameslee97206 is offline   Quote
Old 01-19-2013, 09:36 PM   #4
Join Date: Mar 2010
Location: Warner Robins, GA
Posts: 572
With the cap off and it warm, do you see coolant circulating?
'92 Islander
'06 Rubicon
jkp is offline   Quote
Old 01-19-2013, 09:46 PM   #5
Join Date: Apr 2010
Posts: 10
I let mine run to normal temp with the cap off, then top off the antifreeze and install cap and have not had any problems.
elmoe is offline   Quote
Old 01-19-2013, 09:53 PM   #6
jjone54's Avatar
Join Date: Oct 2012
Posts: 26
Well we got heat going finally and i was just driving down road and it starting getting hot and i shut it off, i tried the squeezing hoses and iam assuming it has still got air pocket or something , i don't think its thermostat because it has never had a problem getting hot before today

jjone54 is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 06:06 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC