Help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-06-2009, 06:02 PM   #1
Jeeper
 
Join Date: Sep 2009
Location: Portland, OR
Posts: 27
Help



So I've got a problem. Aside from being somewhat car-dumb.

Yesterday I was goin' to the range and it started to click and smoke a bit. So I pulled into an auto parts store close by and the people there said the thermostat might just be stuck open.

Today I went to get the radiator system serviced hoping that was just it and the Jiffy Lube guy said that the water pump could be going out and there was a clog in the radiator hose.

Once I left there it drove good for about 20 minutes then it clicked loudly and then die on me in traffic and smoke will come out of the hood. It'll start up again a few seconds later and go for a while and die again...

Any ideas?

Ubergopher is offline   Quote
Old 09-06-2009, 06:15 PM   #2
Jeeper
 
SurfNaked2010's Avatar
 
Join Date: May 2009
Location: Bayville, New Jersey
Posts: 432
Send a message via AIM to SurfNaked2010
from all of these symptoms your engine should of over heated... you didnt get any warning lights, check gauges light nothing?

__________________
W.W.J.D. (What Would Jerry Do???)
SurfNaked2010 is offline   Quote
Old 09-06-2009, 06:22 PM   #3
Jeeper
 
Join Date: Sep 2009
Location: Portland, OR
Posts: 27
Quote:
Originally Posted by SurfNaked2010 View Post
from all of these symptoms your engine should of over heated... you didnt get any warning lights, check gauges light nothing?
Nope. The only gauges that work on it are my speedometer and the odometer.

Basically I own a frankenjeep.
Ubergopher is offline   Quote
Old 09-06-2009, 11:05 PM   #4
Jeeper
 
skeeter's Avatar
 
Join Date: Dec 2006
Location: Spokane, Wa.
Posts: 3,898
Send a message via Yahoo to skeeter
Get your gauges fixed!!!
The "smoke" coming out from under the hood was probably steam from a severely overheated motor. You may well have done serious damage to the motor.
Water pump could be bad. Thermostat may be stuck closed. Radiator may be plugged up. may have a blown head gasket. or several other problems.
Start by replacing the thermostat and flushing the cooling system and filling with good coolant.
Inspect the radiator. look for a bunch of crusty buildup on the little ports. look for any leaks. replace the radiator cap. watch the coolant level to see if you're losing coolant.
__________________
"But it does me no injury for my neighbour to say there are twenty gods, or no god. It neither picks my pocket nor breaks my leg." - Thomas Jefferson, Notes on the State of Virginia, 1782

Arguing with a truck driver is like wrestling with a pig in mud, eventually you realize the pig enjoys it.
skeeter is offline   Quote
Old 09-07-2009, 12:51 AM   #5
Jeeper
 
Join Date: Sep 2009
Location: Portland, OR
Posts: 27
Yeah, that jeep isn't moving again under its own power until I can get it fixed.

There is crusty build up on the ports.

...Anyone know any good mechanics in the Tacoma area?
Ubergopher is offline   Quote
Old 09-07-2009, 11:10 AM   #6
Jeeper
 
skeeter's Avatar
 
Join Date: Dec 2006
Location: Spokane, Wa.
Posts: 3,898
Send a message via Yahoo to skeeter
I don't know anybody over on the wet side but swapping the radiator isn't difficult. My wife just did hers last weekend. She was having some over heating issues as well, swapping out the radiator and water pump cured it.
__________________
"But it does me no injury for my neighbour to say there are twenty gods, or no god. It neither picks my pocket nor breaks my leg." - Thomas Jefferson, Notes on the State of Virginia, 1782

Arguing with a truck driver is like wrestling with a pig in mud, eventually you realize the pig enjoys it.
skeeter is offline   Quote
Old 09-07-2009, 04:18 PM   #7
Jeeper
 
Join Date: Sep 2009
Location: Portland, OR
Posts: 27
Based on the fact I can't find any open mechanics today, looks like I will be doing it myself.

Now I just gotta find a way to get to some place that sells the parts and tools I need to fix it because that is where the real hang up is, not the difficulty...

Then fix it all so I can get to work at 4 in the freakin' morning.


Ubergopher is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:36 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC