Help please!! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-20-2013, 06:34 PM   #1
Jeeper
 
jdiesel218's Avatar
 
Join Date: Mar 2013
Location: The boondocks
Posts: 42
Help please!!

Can anybody help with their input on what it is, i get a crunching almost popping sound and It only happens when I'm going 30 and below and on turning, and sometimes it feels like popping in the floorboard. Could that be from to much of a lift? I have 6" lift.. Any thoughts??

jdiesel218 is offline   Quote
Old 04-20-2013, 06:49 PM   #2
Jeeper
 
Join Date: Mar 2013
Posts: 160
Images: 1
Not saying it is the same issue but mine was doing that last week. I figured I was a mile from home and would check when I got in the driveway. Last turn onto my street and the popping noise stopped but with a big "clank" instead. Pulled in drive and looked and the lower rear traction bar was snapped off at the frame.

wranglerbob1 is offline   Quote
Old 04-20-2013, 06:56 PM   #3
Jeeper
 
jdiesel218's Avatar
 
Join Date: Mar 2013
Location: The boondocks
Posts: 42
Damn the luck. Right? But unfortunately those are looking pretty solid in my case. I can feel a little bit of popping at my feet on the floor board. Maybe bad tranny mounts?
jdiesel218 is offline   Quote
Old 04-20-2013, 06:56 PM   #4
Jeeper
 
jdiesel218's Avatar
 
Join Date: Mar 2013
Location: The boondocks
Posts: 42
Idk
jdiesel218 is offline   Quote
Old 04-20-2013, 08:16 PM   #5
Jeeper
 
mongol's Avatar
 
Join Date: Dec 2011
Location: Pennsylvania
Posts: 101
check your sway bar links
__________________
GO to studio29tattoo.com for the perfect tattoo visit our web site.
mongol is offline   Quote
Old 04-20-2013, 09:02 PM   #6
Jeeper
 
jdiesel218's Avatar
 
Join Date: Mar 2013
Location: The boondocks
Posts: 42
Alright and is that being the grease balloons are bad or the rod connecting is broke it what?
jdiesel218 is offline   Quote
Old 04-20-2013, 09:21 PM   #7
Jeeper
 
jdiesel218's Avatar
 
Join Date: Mar 2013
Location: The boondocks
Posts: 42
I was thinking the tie rod ends but after more researching I went and checked my sway links and they're feeling pretty solid after I gave them a shaking but the rubber on them has some weathering to it

jdiesel218 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 01:11 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC