Help Please with Idle issues... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-11-2013, 09:36 PM   #1
Jeeper
 
Dezmond's Avatar
 
Join Date: May 2012
Location: Delhi Ontario Canada
Posts: 21
Help Please with Idle issues...

Hey Everyone..

It's a 97 TJ with a 2.5. Every time I start it up it will rev up to around 1800 RPM for a few seconds that come back down to under 1k. When I take off when it is cold and start to hit the gas it will idle up again. If I come up to a set of lights and push the clutch in, it will idle high until I stop then idle down.. After it warms up it goes away.. BUT if I pull up to a store and turn it off, run in for a minute or 2 and start it up it revs up again.. Then goes away.

I changed the TPS and IAC sensors.. Cleaned the TB as well really well..

I'm stuck!!! I never did this when I first got it...

ANy other suggestions?? Thanks everyone!!!

__________________
Dezi

97 Jeep TJ 2.5L
Dezmond is offline   Quote Quick Reply
Old 06-11-2013, 09:44 PM   #2
Commercial Member

WF Supporting Member
 
Big Sarge's Avatar
 
Join Date: Dec 2012
Location: Chester Virginia
Posts: 3,006
Check your vacuum lines. Sounds like a vacuum leak to me.

__________________
click the link below to view my Custom Jeep shifters, pool ball shifters. College Teams now available
http://www.wranglerforum.com/f37/custom-camo-pool-ball-shifters-224388.html

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)
Big Sarge is online now   Quote Quick Reply
Old 06-11-2013, 10:46 PM   #3
Jeeper
 
UFOtestpilot's Avatar
 
Join Date: Nov 2012
Location: Portland, Oregon
Posts: 1,818
What kind of shape is your O2 sensor in?
__________________
For some, it is easier to kill the light inside of themselves than it is to fight the darkness all around them.
UFOtestpilot is offline   Quote Quick Reply
Old 06-11-2013, 11:02 PM   #4
Jeeper
 
Dezmond's Avatar
 
Join Date: May 2012
Location: Delhi Ontario Canada
Posts: 21
I think I do have a bad 02. Downstream I believe..

Start THere???
__________________
Dezi

97 Jeep TJ 2.5L
Dezmond is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:29 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC