HELP !!! Weird Going on's & Off's - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-18-2013, 09:18 PM   #1
Jeeper
 
AngeliasDad's Avatar
 
Join Date: Jul 2013
Location: Edmonds, WA
Posts: 24
HELP !!! Weird Going on's & Off's

On my way home from work tonight the RPM and Speedometer bolth dropped to Zero and the Airbag light came on ...... then it went back to normal ..... Drove a little further own the road and it did it again but this time the check engine light came on too...... stayed off and on for about 20 - 30 seconds , didn't do it again after that. I was only going about 35mph when it happened, and I had jut filled the tank up. Any Ideas ???? THX Guys !!!!!

AngeliasDad is offline   Quote Quick Reply
Old 09-18-2013, 09:27 PM   #2
Jeeper
 
Join Date: Jun 2013
Posts: 60
Hmmm, possibly a precursor to battery failure?? I don't know. I had some crazy things happening recently to my car like this, happened off and on for a couple weeks.... Then battery died completely. All made sense after the fact.... But really had me scratching my head before the battery failed. Probably not much help, I'm sure some others will give you some feedback.

BadSweet is offline   Quote Quick Reply
Old 09-18-2013, 11:15 PM   #3
Supporting Member

WF Supporting Member
 
jeepwayoflife's Avatar
 
Join Date: Nov 2011
Location: California/Montana
Posts: 3,165
Sounds like a bad ground or connection for the gauge cluster to me.
__________________
--------------------------------------------------------
jeepwayoflife is online now   Quote Quick Reply
Old 09-18-2013, 11:21 PM   #4
Jeeper
 
Owen_TJ's Avatar
 
Join Date: Sep 2010
Location: Denver, CO
Posts: 4,026
My guess is you have a bad connection with the connectors on the back of the cluster...happened to me once after a really hot day. Took the cluste out and reconnected the plugs and voila...fixed

Took about 15-20 minutes
Owen_TJ is online now   Quote Quick Reply
Old 09-18-2013, 11:44 PM   #5
Jeeper
 
AngeliasDad's Avatar
 
Join Date: Jul 2013
Location: Edmonds, WA
Posts: 24
Easy enough, Thank you, I think I need to order new cluster lights and replace those while I'm at it ....
AngeliasDad is offline   Quote Quick Reply
Old 09-18-2013, 11:53 PM   #6
Jeeper
 
Owen_TJ's Avatar
 
Join Date: Sep 2010
Location: Denver, CO
Posts: 4,026
gotcha...its not hard to do so might as well take it apart now, get the gauges working, put it back together...then just redo it with the lights

plus, you'll be a pro when it comes time to do it the second time lol

Owen_TJ is online now   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 03:31 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC