Help with Heater problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-03-2007, 10:14 PM   #1
Jeeper
 
Join Date: Mar 2007
Posts: 37
Help with Heater problem

2005 TJ the heater is stuck on defrost. it will shut off and the blower will change speeds, but it will not change positions from vent to defrost to feet, etc. is this a common fix? or something it has to go to the dealer for. im still under warranty but if its something i can do myself to save a trip i would like to
thanks

__________________
2005 Wrangler Blue
Full Traction 3"
32" Pro Comp A/T
BPD119 is offline   Quote Quick Reply
Old 12-04-2007, 03:13 PM   #2
Jeeper
 
machine's Avatar
 
Join Date: Aug 2007
Location: lajes field, terceira, azores
Posts: 93
Send a message via Yahoo to machine
same problem on my 98

machine is offline   Quote Quick Reply
Old 12-04-2007, 04:22 PM   #3
Jeeper
 
richp's Avatar
 
Join Date: Mar 2007
Location: Pocono mountains
Posts: 1,559
Two causes, vacum and the cable behind the contols, pretty easy to fix. On the 97 and 98 it maybe a small $15 dollar pin that entails an $800 labor charge, the pin is in the heater box so it's the same as replacing the heater core or the evaporator. I don't think the pin holds true for the newer one, they supposedly fixed it with a steel pin vs the plastic one in the older models but I could be wrong..
richp is offline   Quote Quick Reply
Old 12-04-2007, 10:09 PM   #4
Jeeper
 
Join Date: Mar 2007
Posts: 37
i fixed it, it was the vac line on the drivers side of the motor. its popped off. took me 30 seconds to fix
__________________
2005 Wrangler Blue
Full Traction 3"
32" Pro Comp A/T
BPD119 is offline   Quote Quick Reply
Old 06-10-2008, 08:43 PM   #5
Newb
 
Join Date: Jun 2008
Location: with my Jeep
Posts: 1
I might have a similiar problem (I think)...

My air is stuck on Defrost only. Both cold and hot air works and variable fan speeds work as well but I can not get the air to blow out of the front vents.

Please advise if I have the same problem? Thanks a lot in advance!

Also, sorry, but I am not mechanical. If my problem is the same as this one, could instructions on how to do these task be posted here or emailed to me? I am not afraid to try and adjust/fix it myself. I don't think $1,000.00 + to take off the dashboard that the dealer suggest as a first option is what I would like to do.

A friend suggested a clothes hanger solution was on the internet because some "flapper" was stuck...not finding that solution viable.


Previous entries:
richp wrote:
Two causes, vacum and the cable behind the contols, pretty easy to fix. On the 97 and 98 it maybe a small $15 dollar pin that entails an $800 labor charge, the pin is in the heater box so it's the same as replacing the heater core or the evaporator. I don't think the pin holds true for the newer one, they supposedly fixed it with a steel pin vs the plastic one in the older models but I could be wrong..

BPD11 wrote:
i fixed it, it was the vac line on the drivers side of the motor. its popped off. took me 30 seconds to fix

RSVP,

silentthinking10
silentthinking is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
2400 miles on new jk having trans problem NTJeep JK Tech Forum 4 01-14-2009 01:03 AM
heater problem hank1 TJ Tech Forum 2 11-13-2008 05:35 PM
Heater / Blower Problem 2000 Wrangler dougman1971 TJ Tech Forum 0 09-17-2008 07:56 AM
weird heater switch problem fr87hn TJ Tech Forum 4 04-19-2007 12:36 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 08:24 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC